Forum Thread: Error 12057

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
CSI

This thread has been marked as locked.
heinz.yu Error 12057
Member 9th Dec, 2011 21:04
Ranking: 0
Posts: 5
User Since: 7th Jun, 2011
System Score: N/A
Location: US
Good day!

I've installed the Secunia CSI agent to an endpoint and it is not properly communicating back to my Secunia console.

I've taken a look at the traffic on the firewall and there is nothing being blocked.

I've also placed under the endpoint's Internet Explorer's trusted site *.secunia.com.

I did a manual scan by executing csia.exe -c and I'm getting this exact error:

Error while checking in with server (12057) : ""

Has anyone encountered this issue before?

Any help would be greatly appreciated.

Heinz

heinz.yu RE: Error 12057
Member 9th Dec, 2011 23:43
Score: 0
Posts: 5
User Since: 7th Jun 2011
System Score: N/A
Location: US
Found the answer to my issue:

There was an ACL at the firewall that prevented return traffic back to the host in question.

Heinz
Was this reply relevant?
+0
-0
marykate30 RE: Error 12057
Member 12th Dec, 2011 11:20
Score: 1
Posts: 1
User Since: 12th Dec 2011
System Score: N/A
Location: US
Hi,
I found this on internet.
This error occurs if there is a server certificate revocation problem.
To resolve this issue:
Open Internet Explorer.
From the Tools menu, select Internet Options to display the Internet Options dialog.
Click on the Advanced tab.
Scroll down to the Security section.
Uncheck the Check for server certificate revocation box.
Click on the OK button.
Close all Internet Explorer browsers before retrying.

--
http://www.revitols.com/
Was this reply relevant?
+1
-0
wmahmood RE: Error 12057
Secunia Official 3rd Jan, 2012 21:32
Score: 0
Posts: 32
User Since: 10th Aug 2011
System Score: N/A
Location: Copenhagen, DK
Hi,

If you are getting error message as 12057, then it is possible that your client machine was unable to connect to certificate revocation authority to verify the certificate.

Whenever, CSI agent would scan, it would first check with crl.verisign.net and crl.thawte.com for SSL certificate and code signing certificate.

Please make sure that you have whitelisted http://crl.thawte.com and http://crl.verisign.net at your firewall/proxy.

The workaround you suggested would also work but this is not safe as your system would not check for certificate revocation for any software. We also suggest another workaround. You can install CSI Agent to ignore certificate check with command line option as below:

csia.exe -i -L --ignore-crl (note: two --)

This would result in ignoring the certificate check only for CSI Agent but not for other programs.

Please let us know if you need more explanations.

Best Regards,

Stay Secure

/Waqas

Secunia Customer Support

--
Best Regards,

Waqas Mahmood
Flexera Software Support

This thread has been marked as locked.