Forum Thread: agent for 64-bit install uninstall problems

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
CSI

This thread has been marked as locked.
showtime33 agent for 64-bit install uninstall problems
Member 3rd Jan, 2012 18:16
Ranking: 0
Posts: 17
User Since: 15th Sep, 2011
System Score: N/A
Location: US
I have a workstation that had the agent installed...but it was removed and now it won't install an agent again....because it thinks it is installed....

so I need a way to force the update FROM THE WSUS.....not manually!

the cmdline option will not work....because the agent will NOT have the correct settings.....and I do not have time to find a way to match all the settings...when it is already created.....

where is the right click on a computer and..."install agent" ?????....or FORCE install agent again....exactly like the certificate....


showtime33 RE: agent for 64-bit install uninstall problems
Member 3rd Jan, 2012 18:40
Score: 0
Posts: 17
User Since: 15th Sep 2011
System Score: N/A
Location: US
Last edited on 3rd Jan, 2012 18:45
Here is what I have completed that have not worked:
**removed computer from csi....
**removed computer from wsus...
**removed reg entry under hkey current user...named secunia...
**restarted
**wuauclt /resetauthorization and /detectnow...
**everything back and listed now....pc added to wsus....csi again.....
still no updates needed and no agent installing...
**nothing listed under add/remove programs for secunia at all...
**verified certificate is installed...repeated about 3 times...successfully installed everytime...
**restarted pc 3 times....
**check update....nothing needed...

no agent running....no agent installed....csi reporting agent is installed....

**I forgot to add......cleared up windows update folder (software distribution) (downloads)....for those that do not know......
**emptied...rechecked for updates....redownloaded from wsus....no updates needed....

tried repeatedly...nothing changed...
Was this reply relevant?
+0
-0
wmahmood RE: agent for 64-bit install uninstall problems
Secunia Official 3rd Jan, 2012 20:15
Score: 0
Posts: 32
User Since: 10th Aug 2011
System Score: N/A
Location: Copenhagen, DK
Hi,

When you create a new agent package, it would always appear as needed for all systems, even for those where agent is already installed. You need to approve the update for the groups on your WSUS server.

You can also manually check if agent service is running in the backgroud. If you want to un-install the agent manually, you can run following commands:

csia.exe -r -L (un-installing)
csia -r -X (Deleting Registry)

A normal CSI Agent deployment pacakge would un-install old agent and install the new one.

Please let us know if you need further assistance. Please also mention if you are using CSI 4 or CSI 5.

Best Regards,

/Waqas

Secunia Customer Support

--
Best Regards,

Waqas Mahmood
Flexera Software Support
showtime33 RE: agent for 64-bit install uninstall problems
Member 6th Jan, 2012 17:09
Score: 0
Posts: 17
User Since: 15th Sep 2011
System Score: N/A
Location: US
ok....I don't understand...? when I create a new package...? Do you mean that if I have one workstation agent not working....I have to re-create a whole new agent package to deply to ALL the other workstations...?

this is not a solution and I still have this issue....the workstation...has no agent istalled....but is reporting that is does...


I use admin shares and remote cmdline to check for agent installed......there is none...

???
Was this reply relevant?
+0
-0
showtime33 RE: agent for 64-bit install uninstall problems
Member 6th Jan, 2012 17:19
Score: 0
Posts: 17
User Since: 15th Sep 2011
System Score: N/A
Location: US
After looking over the agents and versions.....I have decided to reinstall the agent package....too ALL workstations.....this is not the best choice....but it will fix my issue...
Was this reply relevant?
+0
-0
wmahmood RE: agent for 64-bit install uninstall problems
Secunia Official 10th Jan, 2012 10:48
Score: 0
Posts: 32
User Since: 10th Aug 2011
System Score: N/A
Location: Copenhagen, DK
Hi,

If you want to install agent on single machine then you shouldn't create an agent deployment package and re-install it to every machine. Rather, you can download the agent manually under Scanning > Scanning via local agent > Agent Download and setup. Go to your target machine and place csia.exe file locally. Open a command prompt with admin privilages and type

csia.exe -i -L

The above command would install the agent maunally. You can also scan the machine with csia.exe -c -L

Best Regards,

/Waqas

Secunia Customer Support

--
Best Regards,

Waqas Mahmood
Flexera Software Support

This thread has been marked as locked.