Forum Thread: criticism with how slow PSI opens

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
jesbion criticism with how slow PSI opens
Member 15th Aug, 2012 21:54
Ranking: -5
Posts: 22
User Since: 14th May, 2010
System Score: N/A
Location: US
I finally had to download the new 3.0 PSI, and found a new format, or at least similar but different. The only criticism I have is how long it takes to see if it is actually working.....After showing the PSI window, it said "Loading", but showed nothing going on for over two to four minutes....I knew from the past how long PSI took to load and gave it longer than I ordinarily would for any other program. Eventually it did show the page, but the point I would like to make is why not show an immediate window and then OK the scan, with the window showing something going on? It would make a lot of users more happy and the general public more aware of what it's doing!

rd52 RE: criticism with how slow PSI opens
Member 16th Aug, 2012 00:24
Score: 21
Posts: 80
User Since: 4th Dec 2008
System Score: N/A
Location: US
I have the same situation. I recently had to re-install my operating system and Secunia 2 was no longer available. Three seems to take forever to load, but other than that it seems to work pretty well. It'd be really nice if Secunia could somehow speed it up.
Was this reply relevant?
+1
-0
Maurice Joyce RE: criticism with how slow PSI opens
Handling Contributor 16th Aug, 2012 01:17
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Last edited on 16th Aug, 2012 11:18
@rd52
Versions 1 & 2 are available & supported if you prefer them.

The links are below my Signature Block or you can find them here:

https://secunia.com/products/consumer/PSI/sys_req/


--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+1
-0
17larry RE: criticism with how slow PSI opens
Member 17th Aug, 2012 01:34
Score: 2
Posts: 3
User Since: 16th Oct 2008
System Score: N/A
Location: AU
Last edited on 17th Aug, 2012 01:36
on 15th Aug, 2012 21:54, jesbion wrote:
I finally had to download the new 3.0 PSI, and found a new format, or at least similar but different. The only criticism I have is how long it takes to see if it is actually working.....After showing the PSI window, it said "Loading", but showed nothing going on for over two to four minutes....I knew from the past how long PSI took to load and gave it longer than I ordinarily would for any other program. Eventually it did show the page, but the point I would like to make is why not show an immediate window and then OK the scan, with the window showing something going on? It would make a lot of users more happy and the general public more aware of what it's doing!


The whole operation of the program (ver 3.0.0.3001) is painfully slow, no matter what you try to do. On an older XP machine, it is almost to the point of being non-functional. Slightly faster on new Win 7 machine.
Was this reply relevant?
+0
-0
Terradon RE: criticism with how slow PSI opens
Member 22nd Aug, 2012 15:48
Score: 9
Posts: 22
User Since: 24th Sep 2009
System Score: N/A
Location: US
It is not only slow to open, but it monopolizes even a relatively fast system until it finishes opening. I hate to open it unless I have time to waste staring at the loading screen, wondering if it is still working. It is so bad that it takes several seconds for ctrl/alt/del to be recognized to open Task Manager to see what's happening.

Don
Win7 64bit
Core2 Quad
8gig ram
~ 1gig free hdd

--
Don
Windows 7 Home Premium 64bit SP1
Intel Core 2Quad 8GB RAM 1000mb lan to cable
Was this reply relevant?
+0
-0
jhp13syseng RE: criticism with how slow PSI opens
Member 22nd Aug, 2012 18:14
Score: 0
Posts: 3
User Since: 10th Jun 2010
System Score: N/A
Location: US
I tried it on both XP Pro SP3, and Win7 Pro SP1. It never finishes loading, even if I leave it running for over an hour.

Any solution, other than waiting for version 4?
Was this reply relevant?
+0
-0
rd52 RE: criticism with how slow PSI opens
Member 22nd Aug, 2012 19:05
Score: 21
Posts: 80
User Since: 4th Dec 2008
System Score: N/A
Location: US
on 22nd Aug, 2012 18:14, jhp13syseng wrote:
I tried it on both XP Pro SP3, and Win7 Pro SP1. It never finishes loading, even if I leave it running for over an hour.

Any solution, other than waiting for version 4?



It never takes more than five or so minutes on my Vista 32 system, it just seems to take forever. I don't know if you tried to uninstall, re-install? If that doesn't help you might try to install version 2. I've used Secunia for quite a few years and find it very useful to keep my computer updated.
Was this reply relevant?
+0
-0

This thread has been marked as locked.