Forum Thread: CSI Opens Firefox when it is not the default browser

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as resolved.
MacNala CSI Opens Firefox when it is not the default browser
Member 3rd Oct, 2012 12:23
Ranking: 1
Posts: 25
User Since: 9th May, 2008
System Score: N/A
Location: UK
I completed a scan of my programs this morning and was notified that the Microsoft Core Services (MSXML) 4 needed manual updating. I had just previously checked with MS and it did not offer an update. When I clicked the manual update icon PSI opened Firefox despite the fact that firefox is not my default browser.
Why?

Post "RE: CSI Opens Firefox when it is not the default browser" has been selected as an answer.
Maurice Joyce RE: CSI Opens Firefox when it is not the default browser
Handling Contributor 3rd Oct, 2012 15:01
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Last edited on 3rd Oct, 2012 16:10
This thread covers MSXML & will certainly fix it using PSI. It should fix CSI if you note what is required to update MSXML 4 to SP3.

https://secunia.com/community/forum/thread/show/13...

Edit: Is the default browser set up correctly in the Registry?

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+1
-0
MacNala RE: CSI Opens Firefox when it is not the default browser
Member 3rd Oct, 2012 16:55
Score: 1
Posts: 25
User Since: 9th May 2008
System Score: N/A
Location: UK
Last edited on 3rd Oct, 2012 17:04
Thanks for the link.

I have deleted the old versions of MSXML and installed the new version 4 SP3 and this has solved the problem. All programs up to date.

Your answer did not say why Firefox was being started instead of the default browser IE9.

I could assume that the XML parsing was going wrong but that might be ambitious of me.

CORRECTION Toppic should read PSI not CSI
Was this reply relevant?
+0
-0
Bruce_F_Hull RE: CSI Opens Firefox when it is not the default browser
Member 3rd Oct, 2012 17:08
Score: 0
Posts: 3
User Since: 29th Dec 2008
System Score: N/A
Location: US
See the thread:

default browser
by yodar444

posted 1 week ago.

--
Bruce F Hull
Was this reply relevant?
+0
-0
MacNala RE: CSI Opens Firefox when it is not the default browser
Member 3rd Oct, 2012 17:16
Score: 1
Posts: 25
User Since: 9th May 2008
System Score: N/A
Location: UK
Last edited on 3rd Oct, 2012 17:21
Cannot find that thread please give full topic title.

CORRECTION found it but it does no give any solution.
If I set IE9 as my default browser in IE it should not open firefox!
When Firefox opens it says it is not my default browser and naturally I click no to prevent it being changed

How do I check that the register has the correct setting/s
Was this reply relevant?
+0
-0
Maurice Joyce RE: CSI Opens Firefox when it is not the default browser
Handling Contributor 3rd Oct, 2012 17:38
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
I asked whether the Registry entry was correct. What is your preferred default browser & I will point you where to look & what to look for.

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+0
-0
MacNala RE: CSI Opens Firefox when it is not the default browser
Member 3rd Oct, 2012 19:45
Score: 1
Posts: 25
User Since: 9th May 2008
System Score: N/A
Location: UK
My default browser is IE9
Was this reply relevant?
+0
-0
Maurice Joyce RE: CSI Opens Firefox when it is not the default browser
Handling Contributor 3rd Oct, 2012 21:04
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK

To look whether IE is set up correctly in the registry follows this:

1. Opening REGEDIT

Click on the Start Orb>typeregedit in the search box>at the top Regedit will appear> click on it & U are now in the Registry.

2. Finding the correct key to check

a. Look in the LEFT PANE & at the top U will see HKEY_CLASSES_ROOT. To the left of that key is an arrow. Click it to reveal a long list of Gobbledygook.
b. Scroll down that list to the entry http Click the arrow to the left and look for SHELL click the arrow to the left of Shell and look for OPEN click the arrow to the left of Open and it will reveal COMMAND

This is what you should see if using a 64 Bit System:

https://skydrive.live.com/#cid=E9EA368CBD08ADB3&id...

Look at the data in the right hand pane & you should see this EXACTLY as written.

"C:\Program Files (x86)\Internet Explorer\IEXPLORE.EXE" -nohome

If using a 32 Bit System you will see this:

https://skydrive.live.com/?cid=E9EA368CBD08ADB3&id...

Once you have checked click the red cross at the top right of the open window.

Is that setting correct?

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+3
-0
MacNala RE: CSI Opens Firefox when it is not the default browser
Member 4th Oct, 2012 09:31
Score: 1
Posts: 25
User Since: 9th May 2008
System Score: N/A
Location: UK
Thanks Maurice,
The command entry pointed to firefox.exe.
I have changed it to the value you gave and my problem is now solved.

Why it got stuck with the firefox entry I cannot guess.
Was this reply relevant?
+0
-0

This thread has been marked as locked.