Forum Thread: Failed to Publish package

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:

This thread has been marked as locked.
Bobu54 Failed to Publish package
Member 15th Apr, 2013 15:17
Ranking: 0
Posts: 2
User Since: 15th Apr, 2013
System Score: N/A
Location: UK
Last edited on 15th Apr, 2013 15:19


I am a new user of CSI and today have been having trouble publishing any package.

I scan a computer and it detects that some new packages need to be created to patch the machine. I then right click on the appropriate package (in Secunia Package System) and choose "create update package". I then accept all defaults changing no settings and then I get the message:

Failed to publish package.
Failed to create .exe file : Cannot determine source file alignment, is it a valid exe file?

This is happening for all packages (Adobe reader, Firefox, Flash player, Quicktime, Java etc...)..

I turned on "enable logging" and get the following output:
"2013-04-15 14:04:31","Item:Adobe Flash Player 10.x, upg:1, arch: 21"
"2013-04-15 14:04:39","HandleDataResponse exported file to 'C:\Users\ADMINI~1\AppData\Local\Temp\2\\Secunia CSI\110e0a5d-c1ff-4e78-ab18-6c5d73fc5729\AdobeFlas hPlayer_10.3.183.68_ax_SPS.exe"
"2013-04-15 14:04:39","Failed to create .exe file : : -2147024895 , Cannot determine source file alignment, is it a valid exe file?"

Is the double backslash in the export path the problem (after \Temp\2\)?
If so, where would I fix this as I can't see any export options in the settings of CSI.

If I omit that extra slash and go to directory in widnows explorer, I can see the file there.
C:\Users\ADMINI~1\AppData\Local\Temp\2\Secunia CSI\110e0a5d-c1ff-4e78-ab18-6c5d73fc5729\

Just to confirm, I change no settings in the wizard.

Appreciate any help on this.

This user no longer exists RE: Failed to Publish package
Secunia Official 17th Apr, 2013 14:49

Please take the following additional steps and answer the additional questions I addressed below:

1. Navigate to Secunia Package System and select to 'Create Update Package' for any program
2. Enable 'Edit Package Content' at step 1 of the Secunia Package Wizard.
3. Press Next button to move to step 2 of the wizard.
4. Click the 'Create SPS File' button.

The above steps will engage SPS to create the same executable file that is anyway built upon publishing of your patch to WSUS. If CSI succeeds to download the executable file, and takes you into a local profile directory where you can see the file 'sps.exe', then the problem may not an SPS issue, it's will be more a WSUS-related problem and we will have to take it from there. Let us know the output of the above steps.

Kind regards,
/Rosen Danailov
Bobu54 RE: Failed to Publish package
Member 17th Apr, 2013 14:58
Score: 0
Posts: 2
User Since: 15th Apr 2013
System Score: N/A
Location: UK
Hi Rosen,

Thanks for the response.

Apologies, I should have updated this thread yesterday to say the problem was solved. In the end, after speaking to Secunia support I had to re-install Secunia and it fixed whatever underlying issues had developed in the last few days.

So with that said, there's no longer any outstanding issues.

Creating an SPS package was not really a viable option in my situation, as the issue was occurring on every single patch, and having to do this for each patch would have been incredibly time consuming if we had to create a SPS for each patch (of which there could be hundreds) and then deploy them manually to each computer. However this facility is useful for when the odd patches failed to install or deploy to computers.

Thanks for taking the time to respond.

Was this reply relevant?
This user no longer exists RE: Failed to Publish package
Secunia Official 17th Apr, 2013 15:23

Thank you for updating us with the status of the issues. Please excuse me to have been unclear in my recommendation to create a patch. I meant that you could choose any of the packages in the SPS list, rather than creating patch for each of them. Once again, thanks for the feedback, we are happy that the problem was solved in timely manner.

Enjoy your day sir.

Kind Regards,
/Rosen Danailov
Secunia Support

This thread has been marked as locked.