Forum Thread: Acrobat 9.5.4 shows as needing update when patched

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
nickpayne Acrobat 9.5.4 shows as needing update when patched
Member 15th Apr, 2013 21:54
Ranking: 4
Posts: 16
User Since: 14th May, 2009
System Score: N/A
Location: N/A
PSI is showing Acrobat (full Acrobat, not Reader) as needing an update when it is fully patched. I applied the 9.5.4 patch when it was released a couple of months ago, and when I select "Check for Update" inside Acrobat, it tells me that no updates are available. The file it is complaining about is C:\Program Files\Adobe\Acrobat 9.0\Acrobat\Acrobat.exe, and when I check the internal version number in that, it is still at 9.5.3, so it looks as though the 9.5.4 update didn't update the exe file.

Rebooting the system and running an fresh PSI scan doesn't make any difference - Acrobat is still shown as needing an update.

wally_s_dad RE: Acrobat 9.5.4 shows as needing update when patched
Member 16th Apr, 2013 09:19
Score: 0
Posts: 1
User Since: 16th Apr 2013
System Score: N/A
Location: TW
I suddenly had same problem appear on both my laptop and PC, although I updated quite some time ago. Acrobat's "About..." shows 9.5.4 but PSI scan says 9.5 needs to be updated to 9.3.3. Curiously though, Acrobat.exe Properties lists File version: 9.5.3.305 on Details tab. However, checking for updates says 'No updates available" with 9.4.5 in the title bar. Nothing on Adobe's Security Bullitens either.
http://blogs.adobe.com/psirt/
9.5.3 was updated back in February
...your guess is as good as mine?
Was this reply relevant?
+0
-0
This user no longer exists RE: Acrobat 9.5.4 shows as needing update when patched
Secunia Official 16th Apr, 2013 09:23
It is a recurring issue that Adobe does not update the file version information for several of their products. Are you able to locate any file from Acrobat which has correct file version information? If so it will be much appreciated if you send us a software suggestion for that specific file. Our FAQ explains how it is done.
http://secunia.com/vulnerability_scanning/personal...

Please make a note in the software suggestion with reference to this thread.
nickpayne RE: Acrobat 9.5.4 shows as needing update when patched
Member 16th Apr, 2013 09:49
Score: 4
Posts: 16
User Since: 14th May 2009
System Score: N/A
Location: N/A
Well, when I booted up and logged in today, PSI is showing all programs as up to date, including Acrobat. When I have a look at the details in PSI for Acrobat, it tells me that the installed version of C:\Program Files\Adobe\Acrobat 9.0\Acrobat\Acrobat.exe is 9.5.4.268, but when I look at the internal version number of that file with Windows Explorer, it still shows as 9.5.3.305.

The files that were actually updated when installing the 9.5.4 patch were C:\Program Files\Adobe\Acrobat 9.0\Acrobat\Browser\nppdf32.dll and C:\Program Files\Adobe\Acrobat 9.0\Acrobat\plug_ins\AcroForm.api, which both show an internal version number of 9.5.4.268. So it looks as though the PSI database has been changed between yesterday and today to cope with this...
Was this reply relevant?
+0
-0
This user no longer exists RE: Acrobat 9.5.4 shows as needing update when patched
Secunia Official 18th Apr, 2013 14:20
Thank you for the software suggestions that we have received. The issue should be fixed by now. If you should still have any trouble then please let us know.

This thread has been marked as locked.