Forum Thread: psi security certificate reported as expired in FF version 22.0

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
joe schmoe psi security certificate reported as expired in FF version 22.0
Member 11th Jul, 2013 14:31
Ranking: 41
Posts: 144
User Since: 26th Nov, 2008
System Score: N/A
Location: US
Last edited on 11th Jul, 2013 14:42

PSI Security certificate reported as expired as of 07/09/2013 (North American date convention) and today's date is 07/11/2013.

FF will block access to the hyper link in PSI version 2.0.0.3003 where one can check how secure their PC is to other PSI users on the main Dashboard page when the hyper link is cliched.. It states that the certificate is untrusted and offers the option of "Get me out of here" in a click-able button where the ratings would otherwise be in the IFRAME window.

It is the section where one can review a state-by-state average security rating if they so wish. This rating system is not available in PSI 3.0 versions.

Dunno why this security certificate has been detected as insecure by Firefox, but I thought you should know and maybe verify if this is actually the case.

Also noted that the PSI program seems to hang for a bit (sometimes for an hour) here at "Verifying Internet Connection...." and I must close the program and then re-initiate the gui instance again to get it to get past the verification phase. This must be done at least once to get the main Dashboard window to display.

Once there I can choose to do a manual scan of the system. Just automatically updated Adobe Flash versions to the latest secure version by (AU), so that works.

Maybe these two issues are related?

EDIT: Fixed typos.

--
XP Pro SP3 P4 3.2 HT 2 GB RAM Avast! 9.0.2018 AIS
Win 7 Home Pro SP1 Pentium D 2.8 3 GB RAM Avast 9.0.2018 AIS
Secunia PSI 2.0.0.3003 XP Pro 32-bit & Win 7 H Pro 64-bit

This user no longer exists RE: psi security certificate reported as expired in FF version 22.0
Secunia Official 11th Jul, 2013 14:53
Thank you very much for reporting. The certificate issue should be fixed by now. Please restart the PSI and let me know if you still see any issues.
joe schmoe RE: psi security certificate reported as expired in FF version 22.0
Member 11th Jul, 2013 15:34
Score: 41
Posts: 144
User Since: 26th Nov 2008
System Score: N/A
Location: US
Wow! That was fast!

All resolved, including the hang issue, so thanks! :) :)

--
XP Pro SP3 P4 3.2 HT 2 GB RAM Avast! 9.0.2018 AIS
Win 7 Home Pro SP1 Pentium D 2.8 3 GB RAM Avast 9.0.2018 AIS
Secunia PSI 2.0.0.3003 XP Pro 32-bit & Win 7 H Pro 64-bit
Was this reply relevant?
+0
-0

This thread has been marked as locked.