Forum Thread: I have a question

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as resolved.
norbert312 I have a question
Member 4th Sep, 2013 18:05
Ranking: 0
Posts: 2
User Since: 4th Sep, 2013
System Score: N/A
Location: DE
Hallo,
Secunia reports repeatedly that some programs need an update. For example:
Microsoft XML Core Services (MSXML) 3.x
Microsoft XML Core Services (MSXML) 3.x (64 bit)
Microsoft XML Core Services (MSXML) 4.x
and more. The update can not be performed. Likewise, the program Skype for Windows 6.x
What can I do?

Post "RE: I have a question" has been selected as an answer.
Maurice Joyce RE: I have a question
Handling Contributor 4th Sep, 2013 18:19
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
You have not given the paths or version numbers that PSI state is vulnerable. Try Solution 1 for MSXML:

MSXML ISSUES

The release note for MSXML 4 are here:
http://download.microsoft.com/download/A/2/D/A2D85...

Please note this SP was released before Windows 7 & 8 was produced therefore there is no mention of compatibility or support once installed - it works flawlessly with Windows 7 on both 32 & 64 Bit systems. I have NOT tested it on my Windows 8 PC because I have no old legacy programmes that require it to be installed.

Firstly, it is important to note the VERSION NUMBER currently installed which PSI gives in the vulnerability report because there are three possible solutions.

Solution 1
If PSI gives a version number starting 4.2 or 4.1 that indicates that the very old MSXML 4 SP2 or even older SP1 is installed which must be MANUALLY upgraded to MSXML 4 SP3 as follows:

Click this link: (please note that the system requirements for this download do state that Windows 7 is supported unlike the release notes)

http://www.microsoft.com/en-us/download/details.as...

Once open activate the clearly marked download link called MSXML.MSI - 2.3 MB.

Once installed run & rerun Windows Update - there are some additional patches for MSXML 4 SP3.

On completion PSI will show MSXML 4 as secure with version 4.30.2117.0. like this:

https://1ncuig.bn1.livefilestore.com/y2piAjXq-K2TJ...

Solution 2
If PSI reveals the path to be 4.3 that almost certainly indicates that the latest Windows Update patch is not installed correctly. Run a Windows Update scan - if that reveals nothing try a manual update using this link:

http://www.microsoft.com/en-us/download/details.as...

Solution 3

If MSXML 4 SP3 BETA is installed ensure it is fully removed prior to using Solution 1. The Release Notes referred.

Hope this helps.

Revised 17:11 04/09/2013









--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+0
-0
Maurice Joyce RE: I have a question
Handling Contributor 4th Sep, 2013 18:22
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Last edited on 4th Sep, 2013 18:40
For Skype - open Skype>Help>Check for Updates

Download the update.

EDIT This is what you should see in the scan results of PSI after a full rescan.

https://1ncuig.bn1.livefilestore.com/y2pu-J9dZAx-e...

Once MSXML & Skype are solved what other issues remain?

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+0
-0
norbert312 RE: I have a question
Member 5th Sep, 2013 11:17
Score: 0
Posts: 2
User Since: 4th Sep 2013
System Score: N/A
Location: DE
All is solved!!! Thanks.
Was this reply relevant?
+0
-0

This thread has been marked as locked.