Forum Thread: Microsoft Update is not installed

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:

This thread has been marked as locked.
thebecky Microsoft Update is not installed
Member 1st Jan, 2014 03:44
Ranking: 0
Posts: 1
User Since: 1st Jan, 2014
System Score: N/A
Location: US

Setting up a brand new Windows 7 64 bit laptop for a friend, and installing Secunia PSI -- of course!

I get the yellow exclamation that "Microsoft Update is not installed" and then click "Install Microsoft Update."

One variation of the error I get is at least funny -- for -- the following:
"There is a problem with this website's security certificate. The security certificate presented by this website was issued for a different website's address. Security problems may indicate an attempt to fool you or intercept any data you send to the server. We recommend that you close this webpage and do not continue to this website." blah, blah, blah ...

If I click to go to the website anyway, it comes right back to:

"Use your Start menu to check for updates.
Windows Update is included in Control Panel. To check for updates:
Click the Start button" ... yada, yada yada ...

Most of the time it just goes straight to the "Use your Start menu to check for updates." I've tried manually typing in the address and it still goes back to "use your start menu etc."

How do I get microsoft update instead of just windows update so that secunia psi will work right?


Maurice Joyce RE: Microsoft Update is not installed
Handling Contributor 1st Jan, 2014 10:50
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Is the Action Centre showing in the Task Tray? Is that showing a problem message?

Have you tried the FixIt tool?


Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
IE & Edge Only
Was this reply relevant?

This thread has been marked as locked.