Forum Thread: Updates not publishing and/or take ages to publish

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:

This thread has been marked as locked.
Fred_Eric_S Updates not publishing and/or take ages to publish
Member 13th Feb, 2014 19:58
Ranking: 0
Posts: 1
User Since: 13th Feb, 2014
System Score: N/A
Location: DE
Last edited on 13th Feb, 2014 19:59

Hi there,

we're using a ConfigMgr 2012 R2 environment on a Server 2012 R2 Host with WSUS on the same machine. Got CSI 7 running with the ConfigMgr Plugin. I was able to successfully import inventory data and hosts and publish a test update package for Apple iTunes.

My user is a member of the local administrators and a member of the local WSUS administrators. Both IE and the ConfigMgr Console are opened with administrative privileges.

However, when I try to publish a package for Adobe Reader 11.x, the publish icon turns and turns and nothing happens. Stopped the process after 45 minutes now. I can see that the Adobe product category has been added and is selectable in the SUP settings of ConfigMgr, however there is no actual update to be found in the Updates node after syncing.

CSI logs in the IE console show nothing related to the ConfigMgr process.

Any tips are apreciated.

Best Regartds,


This user no longer exists RE: Updates not publishing and/or take ages to publish
Secunia Official 24th Feb, 2014 13:42

As you mention that publishing worked for iTunes, I would usually think that publishing works in general for your installation. However, as one package worked, but the second didn't, I would then consider how much different these packages are.

While iTunes is a standard package provided in Secunia as a standalone patch (one installer in the SPS package), Adobe Reader is a combination of multiple files in a single executable. This also means that the size of the Adobe Reader exceeds the normal size of a package.

Could you to try the following in attempt to resolve (or at least to confirm the issue):

1. Go to SPS (Patches in your SC2012 plugin) and launch creation of new Reader 11.x patch
2. At step 2 of SPS, find the direct Reader download URL > right-click > select 'Edit'
3. Copy the download URL and use it to download the file via your IE browser

Question: Did that worked? Does your browser download the file?

4. If the files was downloaded, then you could go back to CSI / SC2012 and use the Add Local File to attach it to your configuration (instead of using a download link). This will speed up the publishing and it will not leave the publishing hang while downloading large files.

4.a) If the file failed to download via IE, than you likely have a general problem downloading this file, or large files in general. You may want to check if you added 'https://*' to the list of Trusted Sites in IE, as well as disable IE ESC if you are working on a server machine.

Generally speaking, the Add Local File function should solve this issue for now. However, if you have restrictions to download large files, please think of moving the CSI/SC2012 plugin to a less-restricted system to avoid such issues in the future.

Let us know if you would need further assistance on that issue.

Kind regards / Stay Secure
Rosen Danailov / Security+
Secunia Customer Support

This thread has been marked as locked.