Forum Thread: Secunia PSI 3.0 is unbelievably bad

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:

This thread has been marked as locked.
karlchwe Secunia PSI 3.0 is unbelievably bad
Member 24th Feb, 2014 08:15
Ranking: 0
Posts: 1
User Since: 24th Feb, 2014
System Score: N/A
Location: US
Last edited on 24th Feb, 2014 08:17

It is incredibly slow to load.

It is incredibly slow to run.

It hogs resources while it is running, so much that it creates lag in typing in Microsoft Word, for instance.

In my installation, it takes literally hours to scan, with no feedback, no error messages, no way to interrupt the scan, etc. The screen is featureless and gives no indication of what the problem is. (I have followed the suggestions in the FAQ to allow Secunia through the firewall. Many times.)

It hangs on the same two pieces of software, over and over again (Adobe Air and Adobe Digital Editions), also with no indication why, no way to stop it, no record of progress, no error messages, nothing. I have manually updated both pieces of software, but Secunia still hangs on them. Apparently it thinks that software is out of date and is trying to update them (the screen shows a yellow "updating" symbol that stays there for hours.

In the past, it detected software that I had previously uninstalled, and didn't detect software that I had installed.

When it was in beta, and then in version 1.0, I used to have it load automatically on startup. When that started to be a serious impediment to using the computers, around version 2.0, I started to run it whenever it occurred to me, about every few months. Now I am thinking of just uninstalling it and taking my chances.


paranoiddelusions RE: Secunia PSI 3.0 is unbelievably bad
Member 26th Feb, 2014 12:02
Score: 2
Posts: 14
User Since: 4th Apr 2010
System Score: N/A
Location: N/A
Last edited on 26th Feb, 2014 12:05
Given the near-infinite number of hardware and software configs, not surprised that everyone's experience is different.
I liked V1 and recommended it to anyone who asked.
Only had a few minor glitches with V2 (like the disappearing tray icon) but still rec'd it.
About 5 minutes after installing V3's radically different and imho gawdawful GUI, I uninstalled it and went back to V2 and kept rec'ing V2 to people (with the caveat to avoid V3.)
A few weeks ago V2 stopped working at the Verifying Internet Connection step. Now, it's displaying the dreaded orange icon in the systray and I can't launch the dang thing.
Tried Maurice's reinstall recommendation on another thread but that hasn't worked.
No way I can deal with V3's GUI much less all you're going through so am looking for an alternative to plug the gap in my multi-layered security scheme caused by this. (sighs and wanders away)
Was this reply relevant?
rd52 RE: Secunia PSI 3.0 is unbelievably bad
Member 26th Feb, 2014 18:42
Score: 21
Posts: 80
User Since: 4th Dec 2008
System Score: N/A
Location: US
Wow, I'm surprised that you're having so much trouble. I have used all the versions starting with Ver.1 . Version 3 is different but all the options that I need are present in Ver.3. On my machine (W7 pro 64) it takes about 30 seconds to load, and no more than 90 seconds to scan. I scan at least once a day. In the options menu I have update handling to notify me. Auto updates seem to take forever, and I can manually do the updates much faster. I also have the detailed view checked. By right clicking or double clicking the programs I am able to access the needed options. To me it is well worth the time that Secunia takes scanning to be able to insure that your programs are up to date.
Was this reply relevant?
bgfores RE: Secunia PSI 3.0 is unbelievably bad
Member 27th Feb, 2014 01:28
Score: 1
Posts: 12
User Since: 25th Nov 2008
System Score: N/A
Location: PH
I have also been experiencing a misstep in trying to start V2 but all I had to do was restart Windows and it would work again.
I have also been checking on the forums to see if there has been an improvement on the complaints for V3 but as it seems there are still some so will have to forego reinstalling V3 for the forseeable future.

Was this reply relevant?

This thread has been marked as locked.