Forum Thread: User ID not recognised

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
Ethelred User ID not recognised
Member 1st Feb, 2016 17:22
Ranking:
Posts: 9
User Since: 16th Apr, 2015
System Score: N/A
Location: UK
I have just successfully reinstalled Secunia PSI but receiving a notification that my PSI user ID cannot be retrieved from Secunia and to check I can connect to https//psi3.secunia.com. I can but still keep getting this notification each time I restart and so am unable to proceed. Any advice appreciated. I was having problems with PSI 2.0 (3.0 never worked properly on my PC) ) aborting scans so decided to uninstall not sure if the two issues are related. I had been using PSI 2.0 successfully until it was uninstalled by a technician whilst my PC was undergoing repairs, it has been aborting scans since ( Starting but skipping to end immediately). I tried reinstalling a couple of times and followed any solutions I came across. Finally decided to use REVO uninstaller to make sure everything completely uninstalled.

Maurice Joyce RE: User ID not recognised
Handling Contributor 2nd Feb, 2016 13:34
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Have you checked a User ID exists in your Registry once you have installed PSI?

It is located at:

HKEY_CURRENT_USER\Software\Secunia\PSI and look for the key named UserID

The ID key should be 50 random numbers and letters long.

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+1
-0
Ethelred RE: User ID not recognised
Member 2nd Feb, 2016 19:48
Score:
Posts: 9
User Since: 16th Apr 2015
System Score: N/A
Location: UK
Thank you Maurice for your suggestion. Unfortunately I seem to have completely uninstalled Secunia, Registry Keys and all in my efforts to fix the scan problem. There is no Secunia entry in the Registry. I have done a System restore, Revo initially created a restore point, and I no longer get an ID notification. However I am basically back to square one as Secunia 3.0 still will not start and Secunia 2.0 skips at first step and aborts. I think it may be time to update my creaking OS and PC.
Was this reply relevant?
+0
-0
Maurice Joyce RE: User ID not recognised
Handling Contributor 4th Feb, 2016 17:50
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Last edited on 4th Feb, 2016 18:00
Are you saying that the System Restore recreated a properly constructed User ID in the Registry? PSI is reliant on that being present and correct.

Have you tried the latest version of PSI released a couple of days ago?

The link is here if you want to try it:

https://secunia.com/PSISetup.exe

Notes:
1. If you use the download link let the installer run - it will auto uninstall any version you have installed.

2. If you use Norton Security the download link will activate Norton File Insight for action by you. Just press TRUST - it is merely information that the link it not well known by the Norton community because it has switched from Secunia to the new owners Flexera.


--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+0
-0
Ethelred RE: User ID not recognised
Member 8th Feb, 2016 14:28
Score:
Posts: 9
User Since: 16th Apr 2015
System Score: N/A
Location: UK
Hi Maurice, thank you for your advice. I have tried Secunia PSI 3.0 but it still will not scan, something is preventing the scan running. My security suite Bullguard is allowing it through. I have also tried 2.0 again but that too still skips from Step 1 to 9 and I get an abort notification. This is what was happening before my, probably, ill advised use of the Revo installer. I was just becoming so frustrated that 2.0 was no longer working properly. You are correct my User ID, and indeed the other Secunia entries in HKEY_CURRENT_USER are now missing although Secunia does appear under Software in HKEY_LOCAL_MACHINE. I only have fairly basic and patchy computer Knowledge and skills but I do understand the importance of keeping programmes up to date. Do you have any further advice as to what I might try to at least get Secunia PSI 2.0 working ? I noticed another person had recently posted similar problems and had eventually managed to get PSI working after reinstalling his OS. I do not feel confident enough in my skills to undertake this task. As I mentioned I am considering upgrading my PC and OS now, as Vista is due to be 'retired' next year anyway.
Was this reply relevant?
+0
-0
Maurice Joyce RE: User ID not recognised
Handling Contributor 8th Feb, 2016 22:45
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
We can try another download to see if it puts the lost keys back.

If you want to try please click this link - http://secunia.com/PSI2Setup.exe

Let the installer run - it will auto uninstall your current PSI files before reinstalling a new copy of version 2.

Once complete try to run a scan - if it fails can you please look again in the registry to see if a new User ID has been created.

I agree it is important to keep programmes up to date but all the effort required in an OS reinstallation is just not worth it given your declared reservation and a requirement to upgrade shortly.

Important browser security can be maintained by using Qualy's Browser Checker. The link is here:
https://browsercheck.qualys.com/

If you use it I would recommend you install the plug in to get the best results.

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+0
-0

This thread has been marked as locked.