Forum Thread: In addition to: PSI 2.0 is end-of-life, upgrade to the latest ver...

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as resolved.
klausus02 In addition to: PSI 2.0 is end-of-life, upgrade to the latest version!
Member 4th Apr, 2017 13:33
Ranking: 89
Posts: 144
User Since: 4th Feb, 2011
System Score: N/A
Location: DE
@H.Hansen
In this thread
https://secuniaresearch.flexerasoftware.com/commun...

you posted:

"While we have left PSI 2 active since then, it has not been supported with any enhancements or engineering over the last 5 years.
Version 2 and older were hosted on servers which reached EOL at the end of March 31, 2017, which drove the need to terminate the PSI 2.0 service."

Over the years we have learned to live with the bugs of PSI 2.0 .

Why didn't you replace PSI 3.0 by PSI 2.0 as a first step?
And why didn't carefully fix the bugs in PSI 2.0 as a second step?

In my view this would have been way better.

- regards
Klaus

Post "RE: In addition to: PSI 2.0 is end-of-life, upgrade to the latest version!" has been selected as an answer.
Anthony Wells RE: In addition to: PSI 2.0 is end-of-life, upgrade to the latest version!
Expert Contributor 4th Apr, 2017 14:57
Score: 2542
Posts: 3,402
User Since: 19th Dec 2007
System Score: N/A
Location: N/A


Hi ,

Your persistence in trying to get Flexera to change their mind is admirable but , from my experience , , is doomed :)))

There was vivid discussion here on the Forum from early launch days , through the PSI 1.x, 2.x up to 3.x .

It is a long gone history , but because 3.x never seemed to leave BETA levels and the SPS patches were less than reliable , then 1.x and 2.x were left in place but their development was frozen .

Now , unfortunately , we are where we are and it is what it is . So version 2.x is as dead as can be RIP :((((

I have installed 3.x and for now it does what it says on the tin !! It is a vulnerability checker and NOT a general updater . I do not know how good the auto-update is now but it is what it is .

You can check this vulnerability versus updater thing with Adobe Air for example which has not had a "Security" update for some months and any/all versions since then show as secure even if they are not the latest version.

At the top of this page (when logged in) you can click on the Advisories tab and then search (by product) to get your SA's there ; another historical 2/3 debate for "Power" users versus newcomers/ordinary users .

The mistakes you refer to are down to poor metadata analysis by Secunia support . You cannot update MSXML v4. to 6. as the PSI wrongly shows (in v2 and v3) but it is EOL and that is useful to know . The .NET 2.x arises because Support are reading one MS bulletin in isolation from reality and making the same update advice mistake . The Secunia rule is anyway not to show an embedded vulnerability if it cannot be updated by the user . This was also the subject of a major discussion some years ago on this Forum .

Morten Hansen has been around Secunia for a long time and the fact he has suddenly (re)appeared here on the Forum could well improve Flexera/Secunia response here ; however , monitoring and responding are not the same and never have been . As I am wont to say ; don't hold your breathe .

Hope this is helpful and clear enuff'

Take care

Anthony


--


It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
+3
-0
Leendert Kip In addition to: PSI 2.0 is end-of-life, upgrade to the latest version!
Contributor 4th Apr, 2017 15:10
Score: 137
Posts: 611
User Since: 22nd Jan 2009
System Score: N/A
Location: NL
Hi Anthony and Klaus. I consider PSI 3 as a usable vulnerability checker. I don't use the automatic update option because I have experienced problems in the past. Update processing stopped suddnely or took a very long time, much longer then using the internal updater. So I let PSI warn me and use the internal updater as standard rourine. PSI works OK except when there are server problems of course.

--
PC: PWA Computers
Intel Core I3 2100 3.1Ghz
Kingston DDR3 ValueRam 4GB 1333
Kingston SSD SV300S 240GB
Windows 7 Home Premium 64bits SP1
Secunia PSI 3.0.0.11005
Internet Explorer 11
Mozilla Firefox 59.0.2NL
Google Chrome 66.0.3359.117

Laptop: MSI GT780DX
Intel Core I5-2450
DDR3 RAM 6GB
Windows 7 Home Premium 64bits SP1
Secunia PSI 3.0.0.11005
Internet Explorer 11
Mozilla Firefox 59.0.2NL
Was this reply relevant?
+2
-1
klausus02 RE: In addition to: PSI 2.0 is end-of-life, upgrade to the latest version!
Member 4th Apr, 2017 15:13
Score: 89
Posts: 144
User Since: 4th Feb 2011
System Score: N/A
Location: DE
Last edited on 4th Apr, 2017 15:18
Anthony,

I'm sorry for my persistence. I'm not trying to get Flexera to change their mind at all.
I'm still upset... :-)

And I don't like flagging programs without any reference and without any chance to prove the flagging.

- regards
Klaus
Was this reply relevant?
+2
-0

This thread has been marked as locked.