Forum Thread: Microsoft XML Core Services (MSXML) 4.x Insecure According To PSI...

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
rusty.07 Microsoft XML Core Services (MSXML) 4.x Insecure According To PSI 3.0
Member 11th Apr, 2017 04:20
Ranking: 16
Posts: 30
User Since: 18th Apr, 2014
System Score: N/A
Location: US
Can't remember if this was flagged under PSI 2.0 or not, but, as you know, version 2 is obsolete now, so I had to install version 3, and it is flagging core services 4.x as end of life.

Clicking on the solution leads me to version 6, but that version is not authorized for Windows 7 (this PC).

Why would Secunia direct me to non-Windows 7 file?

Maurice Joyce RE: Microsoft XML Core Services (MSXML) 4.x Insecure According To PSI 3.0
Handling Contributor 11th Apr, 2017 09:17
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
MSXML 6 is a component of Windows 7, 8, 8.1 and 10. MSXML 3 & 6 which are the current versions which should be showing in the scan results of PSI. They are controlled and updated by Microsoft and should be left alone.

https://en.m.wikipedia.org/wiki/MSXML

The subject of MSXML, in particular MSXML 4, was dealt with extensively on this Forum years ago.

https://secuniaresearch.flexerasoftware.com/commun...

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.379
16 GB RAM
IE & Edge Only
Was this reply relevant?
+2
-0
rusty.07 RE: Microsoft XML Core Services (MSXML) 4.x Insecure According To PSI 3.0
Member 11th Apr, 2017 19:13
Score: 16
Posts: 30
User Since: 18th Apr 2014
System Score: N/A
Location: US
Last edited on 11th Apr, 2017 19:14
Thanks. It will take me some time to go through all of those threads.

Seems like I remember tackling this issue a few years ago, but I can't remember if I just ignored the problem or not.

Any particular reason why Secunia is directing me to a non-Windows 7 file / solution?
Was this reply relevant?
+0
-0
Maurice Joyce RE: Microsoft XML Core Services (MSXML) 4.x Insecure According To PSI 3.0
Handling Contributor 11th Apr, 2017 19:55
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Last edited on 11th Apr, 2017 19:56
As I have already explained MSXML 6 is part of Windows 7 and always has been. PSI continues to mislead users by claiming you can update MSXML 4 by installing MSXML 6 which is impossible because Windows 7,8, 8.1 & 10 already has MSXML 6 installed.

MSXML 4 has been obsolete for years and anyone still running it does so at their own risk.

Much more detail is in the threads I pointed you to.

In a nutshell you already have MSXML 3 & 6 which is updated by Microsoft and should be left alone. What you do about the obsolete MSXML 4 is a personal choice.

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.379
16 GB RAM
IE & Edge Only
Was this reply relevant?
+2
-0

This thread has been marked as locked.