Forum Thread: Mono 2.x & Node.js 0.x

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as resolved.
atitagain50 Mono 2.x & Node.js 0.x
Member 10th Aug, 2017 23:48
Ranking: 0
Posts: 29
User Since: 30th Mar, 2009
System Score: N/A
Location: N/A
This was the first time using Secunia after the latest rush of Windows updates. I am now getting these two programs (Mono 2.x & Node.js 0.x) that Secunia is saying need updated. But, I have never seen them before and have no idea what they are or what they are for. Have tried searching on line, but found very little. I am a bit concerned. Any help or insight as to what they are and what they are for would be greatly appreciated.

Thanks.

Post "RE: Mono 2.x & Node.js 0.x" has been selected as an answer.
Maurice Joyce RE: Mono 2.x & Node.js 0.x
Handling Contributor 11th Aug, 2017 10:43
Score: 12291
Posts: 9,544
User Since: 4th Jan 2009
System Score: N/A
Location: UK
These links give the detail of what they do.

https://nodejs.org/en/

http://www.mono-project.com/

Elements of the projects could be embedded in another programme.

What path does PSI give to the problem? - by right clicking on the PSI scan result entries select show details for the path.

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1709 (Fall Creators Update) Build 16299.64
16 GB RAM
IE & Edge Only
Was this reply relevant?
+1
-0

atitagain50

RE: Mono 2.x & Node.js 0.x
[+]
This reply has been deleted
Maurice Joyce RE: Mono 2.x & Node.js 0.x
Handling Contributor 11th Aug, 2017 18:51
Score: 12291
Posts: 9,544
User Since: 4th Jan 2009
System Score: N/A
Location: UK
You have not posted anything - have you fixed both problems now?

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1709 (Fall Creators Update) Build 16299.64
16 GB RAM
IE & Edge Only
Was this reply relevant?
+0
-0

atitagain50

RE: Mono 2.x & Node.js 0.x
[+]
This reply has been deleted
atitagain50 RE: Mono 2.x & Node.js 0.x
Member 12th Aug, 2017 04:07
Score: 0
Posts: 29
User Since: 30th Mar 2009
System Score: N/A
Location: N/A
Last edited on 12th Aug, 2017 04:09
I just replied again, but the "reply" box is empty after I selected "reply". What is happening? How can I get this information to you? Is there a limit on characters?
Was this reply relevant?
+0
-0
Leendert Kip Mono 2.x & Node.js 0.x
Contributor 12th Aug, 2017 05:48
Score: 118
Posts: 600
User Since: 22nd Jan 2009
System Score: 100%
Location: NL
Hi Maurice, Just let you know that it sometimes happens that a post is blanc. I experienced this several times. Maybe a problem in the forum software.

--
PC: PWA Computers
Intel Core I3 2100 3.1Ghz
Kingston DDR3 ValueRam 4GB 1333
Kingston SSD SV300S 240GB
Windows 7 Home Premium 64bits SP1
Secunia PSI 3.0.0.11005
Internet Explorer 11
Mozilla Firefox 57.0NL
Google Chrome 62.0.3202.94

Laptop: MSI GT780DX
Intel Core I5-2450
DDR3 RAM 6GB
Windows 7 Home Premium 64bits SP1
Secunia PSI 3.0.0.11005
Internet Explorer 11
Mozilla Firefox 57.0NL
Was this reply relevant?
+0
-0

atitagain50

RE: Mono 2.x & Node.js 0.x
[+]
This reply has been deleted

atitagain50

RE: Mono 2.x & Node.js 0.x
[+]
This reply has been deleted
atitagain50 RE: Mono 2.x & Node.js 0.x
Member 12th Aug, 2017 18:19
Score: 0
Posts: 29
User Since: 30th Mar 2009
System Score: N/A
Location: N/A
Maybe this is the problem.... I notice that after I login here, It still shows "Login" symbol on upper right corner of screen.
Was this reply relevant?
+0
-0
Maurice Joyce RE: Mono 2.x & Node.js 0.x
Handling Contributor 13th Aug, 2017 07:23
Score: 12291
Posts: 9,544
User Since: 4th Jan 2009
System Score: N/A
Location: UK
There are no restrictions on the amount of text that can be used in a post. The log in feature should show all the time - it is used to log out as well. Are you trying to cut and paste? I am aware that doing that sometimes creates your problem.



--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1709 (Fall Creators Update) Build 16299.64
16 GB RAM
IE & Edge Only
Was this reply relevant?
+1
-0
atitagain50 RE: Mono 2.x & Node.js 0.x
Member 13th Aug, 2017 15:03
Score: 0
Posts: 29
User Since: 30th Mar 2009
System Score: N/A
Location: N/A
The first time was actual typing...after that I used copy and paste...
Was this reply relevant?
+0
-0
atitagain50 RE: Mono 2.x & Node.js 0.x
Member 13th Aug, 2017 15:14
Score: 0
Posts: 29
User Since: 30th Mar 2009
System Score: N/A
Location: N/A
Going to try something here...

when I click on "show details" of the Mono 2.x, I get the following.. "Mono 2.xFile location (doubleclick to open)Installed version
C:\Program Files\Unity\Editor\Data\Mono\lib\mono\2.0\ilasm.ex e 2.6.5.0"
Was this reply relevant?
+0
-0
atitagain50 RE: Mono 2.x & Node.js 0.x
Member 13th Aug, 2017 15:14
Score: 0
Posts: 29
User Since: 30th Mar 2009
System Score: N/A
Location: N/A
and when I click on "more information" I get sent to the following web site "https://secuniaresearch.flexerasoftware.com/adviso..." and get the following message..
"""Secure Connection Failed
Was this reply relevant?
+0
-0

atitagain50

RE: Mono 2.x & Node.js 0.x
[+]
This reply has been deleted

atitagain50

RE: Mono 2.x & Node.js 0.x
[+]
This reply has been deleted

atitagain50

RE: Mono 2.x & Node.js 0.x
[+]
This reply has been deleted
atitagain50 RE: Mono 2.x & Node.js 0.x
Member 13th Aug, 2017 15:17
Score: 0
Posts: 29
User Since: 30th Mar 2009
System Score: N/A
Location: N/A
The page you are trying to view cannot be shown because the authenticity of the received data could not be verified.
Please contact the website owners to inform them of this problem."""
Was this reply relevant?
+0
-0

atitagain50

RE: Mono 2.x & Node.js 0.x
[+]
This reply has been deleted
atitagain50 RE: Mono 2.x & Node.js 0.x
Member 13th Aug, 2017 15:25
Score: 0
Posts: 29
User Since: 30th Mar 2009
System Score: N/A
Location: N/A
And when I click on "more information" for Node.js, I get the following.. "File location (doubleclick to open)Installed version
C:\Program Files\Unity\Editor\Data\Tools\nodejs\node.exe 0.12.7"

And when I click for more information I get this web site " https://secuniaresearch.flexerasoftware.com/adviso..." with the same error message as with the Mono 2.x site.

Now here's the kicker, These web sites came up using Firefox. While I do have Firefox browser on my computer, I have Chrome as my default browser. How or why it opened in Firefox, I have no idea.


Was this reply relevant?
+0
-0
atitagain50 RE: Mono 2.x & Node.js 0.x
Member 13th Aug, 2017 15:25
Score: 0
Posts: 29
User Since: 30th Mar 2009
System Score: N/A
Location: N/A
with both Node.js and Mono, more info selection gets me to this code.. Error code: SEC-ERROR-BAD-SIGNATURE
Was this reply relevant?
+0
-0
Maurice Joyce RE: Mono 2.x & Node.js 0.x
Handling Contributor 13th Aug, 2017 16:53
Score: 12291
Posts: 9,544
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Last edited on 13th Aug, 2017 17:12
PSI is pointing you to a programme called UNITY as the host of both problems. That programme needs updating to the latest version. If not possible you should notify the vendor that they have two vulnerable files embedded in their programme.

EDIT.
Sorry I cannot help or comment on third party browser issues as I only use IE. What I can state is that all the links you have published opened perfectly for me and I was able to read all the Flexera detail offered.



--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1709 (Fall Creators Update) Build 16299.64
16 GB RAM
IE & Edge Only
Was this reply relevant?
+1
-0
atitagain50 RE: Mono 2.x & Node.js 0.x
Member 13th Aug, 2017 21:35
Score: 0
Posts: 29
User Since: 30th Mar 2009
System Score: N/A
Location: N/A
Thank You, I will check into the Unity Player.... I had to put this message out there to this forum in sections and found out that it was the error message that would not go through. Any I will check into Unity and see what if anything I cam find out.
Was this reply relevant?
+0
-0
atitagain50 RE: Mono 2.x & Node.js 0.x
Member 14th Aug, 2017 00:32
Score: 0
Posts: 29
User Since: 30th Mar 2009
System Score: N/A
Location: N/A
OK....this is a mess.....turns out that Unity is a part of Microsoft Visual Studios ... So, i went to Microsoft store and downloaded (free) the latest they had to offer Visual Studio 2017....then had to download from the same site "visual C++ runtime" because apparently, While Visual Studios is for Windows 10 mainly it is designed for 64Bit systems, and i have a 32 bit system. So after all that downloading and installing, I ran Secunia again.....same problem arises. At this point I was so frustrated...So....checked into this Visual Studio program etc, and come to find out, it is not a necessity for those like me who are NOT developers. I have no idea at all how to use ANY of the "tools" provided in the programs. SO I tried deleting them from my computer through settings. Pop-up said it was uninstalled, but after reboot, I checked again..and lo and behold, same issues. SO, I dug into my computer (after doing a complete backup) and deleted anything that had to do with Visual Studio's (any year, as there were many years I was unaware that had been installed without my knowledge) as well as any having to do with the Mono 2.x or the Node.JS.

After deleting and restarting, did another Secunia scan.. All Is WELL !!!!! yayy...and so far everything else is working as it should. But the programs are still showing up in me start menu. That's puzzling.

At this point, I am just going to wait and see...I even checked for updates through Update Center. my machine is up to date.

By the way, I run Window 10 Pro on a 32 Bit system.
Was this reply relevant?
+0
-0
Maurice Joyce RE: Mono 2.x & Node.js 0.x
Handling Contributor 14th Aug, 2017 21:51
Score: 12291
Posts: 9,544
User Since: 4th Jan 2009
System Score: N/A
Location: UK
The reason it still shows at start up may be due to the fact you have not cleared up the dross.

PSI gave you a file path of C:\program files\UNITY - that indicates you have a standalone programme called Unity installed.

This looks to be correct as Visual Studio supports the standalone Unity 3 as can be seen here:
https://blogs.msdn.microsoft.com/visualstudio/2016...

The download to Unity is here:
https://store.unity.com/

The latest release dated 11th August is here which I assume clears the vulnerability.
https://unity3d.com/unity/qa/patch-releases

Is PSI still showing Unity as installed but secure or has it "disappeared"?

I would go to Start> Settings> Apps> Apps and Features and then look for Unity or you can look in Control Panel> Program and Features or type Unity into Contana see if that reveals anything.

Hope this helps





--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1709 (Fall Creators Update) Build 16299.64
16 GB RAM
IE & Edge Only
Was this reply relevant?
+1
-0
atitagain50 RE: Mono 2.x & Node.js 0.x
Member 15th Aug, 2017 01:52
Score: 0
Posts: 29
User Since: 30th Mar 2009
System Score: N/A
Location: N/A
It has disappeared. And so far I have had no problems with any features or programs etc without Unity installed. I had installed with the Facebook Gameroom. Was having problems with it and the error message suggested checking unity installation. So, I did and even downloaded the latest versin they had at the time. But The Gameroom app still did not work properly. So I uninstalled the Gameroom app and forgot about the unity app until this popped up. But now, everything "seems" to be OK.

Thank You everyone that helped with this. I Love Secunia as it saves me and allot of others, many hours of searching etc. And the fact it is free is best of all for me. Am on limited income.
Was this reply relevant?
+0
-0

This thread has been marked as locked.