Forum Thread: PSI says Firefox needs updating but its up to date

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
jckinnick PSI says Firefox needs updating but its up to date
Member 22nd Mar, 2018 02:17
Ranking: 6
Posts: 195
User Since: 21st May, 2010
System Score: N/A
Location: US
Do I need to go that folder and delete the old version?

No one has replied to this thread yet - be the first
This thread has been marked as locked.