Forum Thread: Problem with Cygwin programs (Ruby)

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Open Discussions

This thread has been marked as resolved.
jcpedersen Problem with Cygwin programs (Ruby)
Member 18th Aug, 2010 09:38
Ranking: 0
Posts: 4
User Since: 28th Aug, 2009
System Score: N/A
Location: DK
For some time now I have had a category 2 security threat on Ruby 1.8.x.

The problem is, that this ruby installation is in my Cygwin installation, and (to my knowledge) is the latest version released (1.8.7 (2008-08-11 patchlevel 72) [i386-cygwin])

I do have a regular (windows) ruby v1.9.1p378, and this is OK, but what do I do with the Cygwin version ?

And what to do generally with Cygwin programs ?


Post "RE: Problem with Cygwin programs (Ruby)" has been selected as an answer.
This user no longer exists RE: Problem with Cygwin programs (Ruby)
Member 18th Aug, 2010 09:52
Hi,

The latest secure version of Ruby 1.8.x is 1.8.7.301, as according to this advisory: http://secunia.com/advisories/41003/

Unfortunately, besides pointing out the latest secure version, there is little I can do. Secunia do not prepare or release patches for third-party software, so I have no way to tell if if/how it's possible to update a Cygwin installation of ruby.

However, I hope you might find this link useful in updating your system:
http://cygwin.com/cygwin-ug-net/using-utils.html#c...

If you have other questions, please do not hesitate to ask.
Was this reply relevant?
+0
-0

This thread has been marked as locked.