Forum Thread: Can't remove Flash 10h.ocx

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:

Relating to this vendor:
Adobe Systems
And, this specific program:
Adobe Flash Player 10.x

This thread has been marked as locked.
safetyfirst Can't remove Flash 10h.ocx
Member 20th Aug, 2010 19:56
Ranking: 0
Posts: 1
User Since: 7th Feb, 2008
System Score: N/A
Location: US
Secunia led me to the folder where this file is installed. I used Adobe Flash Player Remover to remove all other elements of Flash Player, including current version of Flash 10h.ocx. It would not remove this one (modified 8/2/2010). I have tried several remove and/or destroy and/or wipe programs to get rid of this and nothing works. I keep keeping message it is in use by another app. I have confirmed via Task Manager that nothing else is open.

How do I get rid of this thing?

I am concerned that this is a rogue active X control.


dracudok RE: Can't remove Flash 10h.ocx
Member 20th Aug, 2010 21:22
Score: 42
Posts: 26
User Since: 14th Jun 2009
System Score: N/A
Location: DE

if you want to identify the program that blocks the file, please download the tool "handle" from SysInternals (

Open a command prompt with administrative rights, change to the download folder of the tool and type

handle Flash10h.ocx

As a result the tool tells you all programs, that access Flash10h.ocx.
Close them all and then you should be able to delete Flash10h.ocx.

Was this reply relevant?
thedillpickl RE: Can't remove Flash 10h.ocx
Contributor 21st Aug, 2010 02:42
Score: 376
Posts: 872
User Since: 3rd May 2009
System Score: N/A
Location: US
Hi safetyfirst;

Welcome to the Secunia forum.

It may be PSI that is keeping Flash open.

> Use PSI to lead you, again, to where the .ocx file is.
> Right click on the PSI icon in the system tray (bottom right).
> Click on "Exit", click on "Yes" in the pop-up.
> Close any open browsers.

Can you now delete the "h" .ocx file? If no, follow dracudok's advise.



XP Home
Chrome, Firefox, IE8
consilio et animis
Was this reply relevant?
Canon09 RE: Can't remove Flash 10h.ocx
Member 25th Aug, 2010 00:25
Score: 3
Posts: 7
User Since: 25th Aug 2010
System Score: N/A
Location: N/A
Last edited on 25th Aug, 2010 00:27
I also cannot remove FLASH10H.OCX at this path:

I ran Process Explorer to see what program might be using that file, but it says nothing is using it.

Windows 7 Home Premium, I'm an Administrator.


Edited: I read this thread again for the 3rd time and finally saw the suggestion to Exit the Secunia program in the system tray. I was finally able to delete the FLASH10H.OCX file.
Was this reply relevant?
F_BIG RE: Can't remove Flash 10h.ocx
Member 26th Aug, 2010 02:16
Score: 4
Posts: 19
User Since: 14th May 2009
System Score: N/A
Location: US
Last edited on 26th Aug, 2010 02:17
For CLI folks, I concur with the recommendation of SysInternals Handle.exe to check
For GUI folks, OpenedFilesView.exe from NirSoft works fairly well.

Both of these will force open handles closed, which may be the thing keeping the flash ocx open. (However, from reading and practice, I'd infer that they won't close a kernel opened file.)

If I cannot get the file closed with one of these or similar utilities, I will use SysInternals MoveFile.exe with the destination file being a null specification, and restarting. This generally keeps me from having to bring up safe mode, which would be my next to last option, the last being booting another OS (a live Linux for example) or OS copy like UBCD4Win.

The other thing that you have to watch out for in this situation is the ACL's, and there are several "TakeOwn" scripts running around to handle that issue.
Was this reply relevant?

This thread has been marked as locked.