Forum Thread: Can't open 2.0 or drop back to

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI 2.0 Beta

This thread has been marked as locked.
MALLYDALLY 1 Can't open 2.0 or drop back to
Member 9th Sep, 2010 20:54
Ranking: 0
Posts: 3
User Since: 20th Dec, 2007
System Score: N/A
Location: N/A
2.0 appears to install flawlessly. Then when ckicking to open the PSI window it flashes up for a few milliseconds then disappears never to be seen again. I have tried to rollback to which reports successful install but then does exactly the same problem. I have been through the install / uninstall cycle three times and also used a professional uninstaller program to make sure no dross is left in the registry and the program folder is completely cleared out. I also notice that when moving the pointer over (but not clicking on) the PSI icon in the bottom right hand side tray it immediately disappears.

I'm no technical expert but would warmly welcome any ideas please. Thank you.

Anthony Wells RE: Can't open 2.0 or drop back to
Expert Contributor 9th Sep, 2010 22:00
Score: 2542
Posts: 3,402
User Since: 19th Dec 2007
System Score: N/A
Location: N/A
Last edited on 9th Sep, 2010 22:02
Hello mallydally ,

Seems like you use XP SP3 and have caught the dreaded update bug found/discussed here ;-

If so , you need to go back to version of the PSI ; here's the link from the thread :-

Lower down in the thread is a workaroungd to get the Beta to run .

Hope this resolves your problem .

Let us know how you go .



It always seems impossible until its done.
Nelson Mandela
Was this reply relevant?
MALLYDALLY 1 RE: Can't open 2.0 or drop back to
Member 9th Sep, 2010 22:45
Score: 0
Posts: 3
User Since: 20th Dec 2007
System Score: N/A
Location: N/A
Thank you very much indeed for your prompt response Anthony. What would old Malc do without help, so willingly given, by really nice people like you.

As you correctly surmised I am a long standing member of the 'XP/SP3 Club' and the rollback to worked a treat. Sorry I did not know about the problem but I've been using without any problem since the day it was released.

That is an extremely long thread (no surprise there then) and with Secunia being fully aware of the issue I think I will sit on my hands in the hope that it gets resolved by the time 2.0 RC hits the streets.

All the best

Was this reply relevant?
This user no longer exists RE: Can't open 2.0 or drop back to
Member 10th Sep, 2010 09:14

We have prepared some parameters to work around this issue. For the following information to apply, you need to be running the PSI 2.0 Beta, which can be had here

If the Secunia PSI still does not run after simply installing the beta, try closing it down and following this procedure.

First, open the "cmd" program. You can do this by typing "cmd" in either the "run" box (Found under Start in XP), or directly in the search field (under start in Vista and Win7).

Then, type "cd "C:\Program Files\Secunia\PSI"", preserving the quotes around the path. From here, you can run the PSI with different options. Before doing this, and before attempting to try another option, it is very important to close every running instance of the PSI, by right-clicking the tray icon and selecting Quit.

Try running the PSI with this command: "psi.exe --dep-allow-atl-emu --verbose --debug secunia.txt".

If the above option did not help your PSI installation to run correctly, please close down any running instances of the PSI, and repeat the run with this command:
"psi.exe --no-force-dep --verbose --debug secunia.txt".

If running with either of these options does not correct the problem, please email the "secunia.txt" file, which was created in "C:\Program Files\Secunia\PSI", to Do NOT post any information from the log here, as the information contained within is specific to you.

If either of these options makes your PSI run successfully, terminate the PSI and repeat the command that worked, this time adding the "-S" flag, and not adding the "--verbose" or "--debug" flags. Running with "-S" saves your options for future use. An example of a full command, which also saves the setting, is "psi.exe --no-force-dep -S", which will store the "--no-force-dep" option for the future.

If you save a setting, and wish to return to default settings, run the PSI with this command: "psi.exe -Z", which will remove all PSI settings stored in the registry.

hope this helps.
Was this reply relevant?

This thread has been marked as locked.