Forum Thread: an error occured while attempting to open specified URL

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI 2.0 Beta

This thread has been marked as resolved.
runrig an error occured while attempting to open specified URL
Member 20th Sep, 2010 12:42
Ranking: 3
Posts: 26
User Since: 29th Aug, 2010
System Score: N/A
Location: UK
I recently had Chrome as my default browser, had to uninstall, which made IE9 Beta, I'm testing, my default browser ... fine for now.

I just wanted to check results in PSi and automatically used the "post your comments, feedback, suggestions, and bugs today" internal PSI linkie, only to be confronted with ... an error occured while attempting to open specified URL ... checked all setting, inc regedit, and IE is default browser, it's the only browser.

will leave it this way, for the day, so you may have a solution for me ... yeah, reinstall Chrome ;)


Regards
runrig

TTFN

--
heaven doesn't want me, and hell is afraid I'll take over

Post "RE: an error occured while attempting to open specified URL" has been selected as an answer.
This user no longer exists RE: an error occured while attempting to open specified URL
Member 20th Sep, 2010 13:59
Hi,

Please try the steps outlined in this post: http://secunia.com/community/forum/thread/show/471...

Has this resolved the issue?
Was this reply relevant?
+0
-0
runrig RE: an error occured while attempting to open specified URL
Member 20th Sep, 2010 14:11
Score: 3
Posts: 26
User Since: 29th Aug 2010
System Score: N/A
Location: UK
Last edited on 20th Sep, 2010 14:16
on 20th Sep, 2010 13:59, wrote:
Hi,

Has this resolved the issue?

err, sorry, no

as I said

(unknown source)
checked all setting, inc regedit, and IE is default browser, it's the only browser.

I repeat, regedit says IE is default browser, I'm very competent in using regedit ;) ... IE is the only browser installed at the moment.

I must say, you peeps are second to non in replying to Beta queries, wish other programmes would take a leaf out of your book.

ah, one sec, I haven't re-booted the system, BRB :)

regards
runrig

[edit]a reboot did not resolve the problem :(

--
heaven doesn't want me, and hell is afraid I'll take over
Was this reply relevant?
+0
-0
This user no longer exists RE: an error occured while attempting to open specified URL
Member 21st Sep, 2010 08:35
Hi,

What is the contents of this registry key?
HKEY_CLASSES_ROOT/HTTP/shell/open/command

This is the browser the PSI will use by default.

If this is not Internet Explorer, try first uninstalling the PSI, then setting IE as your default browser (Yes, again) by following these instructions: http://www.winxptutor.com/iedefault.htm
When this is done, try reinstalling the PSI, which can be fetched from here: http://secunia.com/PSISetup.exe in the current stable version, or here: http://secunia.com/PSI2SetupBeta.exe for the PSI 2.0 Beta.

hope this helsp.
Was this reply relevant?
+0
-0
runrig RE: an error occured while attempting to open specified URL
Member 21st Sep, 2010 11:28
Score: 3
Posts: 26
User Since: 29th Aug 2010
System Score: N/A
Location: UK
Last edited on 21st Sep, 2010 11:58
hmmm, sorry once again but I'm using Win7 ... instructions on resetting IE9 are a wee bit different to the link you gave for XP

as I said, not trying to be flippant here, but IE9 is the default browser, it is the ONLY browser on my system

been busy, should have done the classic, uninstall reinstall PSI ... will do so at sometime today.


regards
runrig


TTFN

[edit] my sincere apologies, I forgot to check ... What is the contents of this registry key?
HKEY_CLASSES_ROOT/HTTP/shell/open/command

it does indeed point to Chrome

[edit2] uninstall, reinstall had no effect

--
heaven doesn't want me, and hell is afraid I'll take over
Was this reply relevant?
+0
-0
runrig RE: an error occured while attempting to open specified URL
Member 21st Sep, 2010 13:20
Score: 3
Posts: 26
User Since: 29th Aug 2010
System Score: N/A
Location: UK
tidied up the registry, error now is ...

"Unable to locate an appropriate web browser for the requested URL"

followed by

"an error occured while attempting to open specified URL"

mind you, IE9 Beta isn't there in ...

HKEY_CLASSES_ROOT/HTTP/shell/open/command

... actually, nor is command



I love Beta testing :)

--
heaven doesn't want me, and hell is afraid I'll take over
Was this reply relevant?
+0
-0
This user no longer exists RE: an error occured while attempting to open specified URL
Member 21st Sep, 2010 14:07
Last edited on 21st Sep, 2010 14:07 Hi,

While it is possible to set the Internet Explorer 9 Beta as the default browser, the registry key seems to refuse to change unless all other browsers on the system are uninstalled. I had both the IE9 Beta and Firefox 3.6.10 on the same system, and while changing settings in the control panel had no effect, uninstalling Firefox did. I suggest you go to "Programs and Features" in the control panel, and ensure that no browsers apart from the IE9 Beta are installed.

If this is already the case, you can manually change the contents of the registry key (Note: This is only a good idea if you are already comfortable working with the registry. The contents of the registry are crucial to your system, and having the wrong settings can effectively break your installation. If you feel unsure about working with the registry, it is better not to. Doing so anyway happens entirely on your own risk).

The contents of the HKEY_CLASSES_ROOT\HTTP\shell\open\command key on my 64-bit Win7 system is:
"C:\Program Files(x86)\Internet Explorer\iexplore.exe" -nohome
And the PSI seems to handle the IE9 Beta properly as the default browser.

hope this helps.
Was this reply relevant?
+0
-0
runrig RE: an error occured while attempting to open specified URL
Member 21st Sep, 2010 16:20
Score: 3
Posts: 26
User Since: 29th Aug 2010
System Score: N/A
Location: UK
Hello again;

I can assure you IE9 is the only browser in use on this system at the moment. :)

After reinitialising the proper pointer in the registry I now only get the one error message when using the direct link within Secunia PSI ...

"an error occured while attempting to open specified URL"

dispite the contents of the HKEY_CLASSES_ROOT\HTTP\shell\open\command key on my 64-bit Win7 system as:
"C:\Program Files(x86)\Internet Explorer\iexplore.exe" -nohome
I still get the URL error

regards
runrig

TTFN

--
heaven doesn't want me, and hell is afraid I'll take over
Was this reply relevant?
+0
-0
This user no longer exists RE: an error occured while attempting to open specified URL
Member 22nd Sep, 2010 10:17
Hi,

Are you on a 64-bit system? If this isn't the case, then the "C:\Program Files(x86)" path may not be correct for you.

Try browsing through your C:\ Drive, and find the correct path to your iexplore.exe file. It is very important that the path in the registry match the location of this file on your physical drive.

Has correcting the path resolved the issue?
Was this reply relevant?
+0
-0
runrig RE: an error occured while attempting to open specified URL
Member 22nd Sep, 2010 10:35
Score: 3
Posts: 26
User Since: 29th Aug 2010
System Score: N/A
Location: UK
yes, 64bit Win 7 home premium, IE9 Beta 64bit and Adobe's attempt at a 64bit flash activex plugin aptly called square ;-)


regards
runrig





--
heaven doesn't want me, and hell is afraid I'll take over
Was this reply relevant?
+0
-0
This user no longer exists RE: an error occured while attempting to open specified URL
Member 22nd Sep, 2010 11:03
Hi,

Is the path now contained in the registry exactly the same as the actual path to your Internet Explorer installation?

If so, could I ask you to provide us with a debug log? To obtain such a log, first shut down the PSI by right-clicking the icon in the tray, and selecting Exit.
Now, type "cmd" in the search bar (under the start menu), and enter these commands:
cd %ProgramFiles%\Secunia\PSI
psi.exe --verbose --debug secunia.txt

The PSI will now run in debug mode. Please reproduce the steps that lead to the issue, and send us the "secunia.txt" file created in the %ProgramFiles%\Secunia\PSI folder, at support@secunia.com. Please not that it is very important that you do not post any parts of the debug log on the forum, as it will contain information specific to you.

hope this helps.
Was this reply relevant?
+0
-0
runrig RE: an error occured while attempting to open specified URL
Member 22nd Sep, 2010 17:53
Score: 3
Posts: 26
User Since: 29th Aug 2010
System Score: N/A
Location: UK
Last edited on 22nd Sep, 2010 17:54
Hello

Microsoft Windows [Version 6.1.7600]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Windows\system32>cd %ProgramFiles%\Secunia\PSI
The system cannot find the path specified.

C:\Windows\system32> psi.exe --verbose --debug secunia.txt
'psi.exe' is not recognized as an internal or external command,
operable program or batch file.

C:\Windows\system32>
C:\Windows\system32>


I throw the ball back :)

be aware your program is listed/installed in ...
"C:\Program Files (x86)\Secunia\PSI"
... dunno why

regards
runrig

--
heaven doesn't want me, and hell is afraid I'll take over
Was this reply relevant?
+0
-0
This user no longer exists RE: an error occured while attempting to open specified URL
Member 23rd Sep, 2010 09:54
Hi,

Try these commands:

cd "C:\Program Files (x86)\Secunia\PSI"
psi.exe --verbose --debug secunia.txt

Does this start the PSI in the debug mode? If so, please reproduce the steps that lead to the issue, and send us the report as explain in the post above.
Please also remember that it is important not to post any parts of the log file here.

hope this helps.
Was this reply relevant?
+0
-0
runrig RE: an error occured while attempting to open specified URL
Member 23rd Sep, 2010 10:45
Score: 3
Posts: 26
User Since: 29th Aug 2010
System Score: N/A
Location: UK
email sent, I think


thank you for your time

regards
runrig

--
heaven doesn't want me, and hell is afraid I'll take over
Was this reply relevant?
+0
-0
This user no longer exists RE: an error occured while attempting to open specified URL
Member 23rd Sep, 2010 10:50
Hi,

While the PSI was running in debug mode, did you reproduce the error?
The log file I have received (marked "runrig") does not mention attempting to open any links.

This is rather essential for the debug log to actually be helpful. :)
Was this reply relevant?
+0
-0
runrig RE: an error occured while attempting to open specified URL
Member 23rd Sep, 2010 11:24
Score: 3
Posts: 26
User Since: 29th Aug 2010
System Score: N/A
Location: UK
Last edited on 23rd Sep, 2010 12:22
yes, I attempted to link, from all posible linkage from within PSI ... got the same error

Not a worry, will have to reinstall Chrome to save my sanity, only taken about 9 years for Adobe to attempt anything 64bit, and it fails ever time you try and "view" anything that "needs" it in IE9 64 ... as per my experience, it's not Microsoft's fault, it's 3rd party, again!!

I conceed defete, as I can only put up with these annoyences for so long :(


... and I miss the speelchecktered ;-)


[edit] sent another email with lots of "pressing" of linky buttons :)

--
heaven doesn't want me, and hell is afraid I'll take over
Was this reply relevant?
+0
-0
This user no longer exists RE: an error occured while attempting to open specified URL
Member 23rd Sep, 2010 12:30
Hi,

Okay, maybe better to leave it here. These kind of issues should all have been ironed out before the final release of Secunia PSI 2.x.

Specifically the current handling of browsers is one of the things we will be looking into improving before the final 2.x release. We do realize that the current situation, where corruption in the registry can cause breakage, is hardly ideal. However, it really should work for those users who are running a stable version of IE instead of the Beta - The Beta simply doesn't set the registry keys that it should.

Thank you for all your feedback.
Was this reply relevant?
+0
-0
runrig RE: an error occured while attempting to open specified URL
Member 23rd Sep, 2010 13:35
Score: 3
Posts: 26
User Since: 29th Aug 2010
System Score: N/A
Location: UK
you is more than welcome, you have a great program.

thank you


regards
runrig

ps, I'll still be around ;-)

--
heaven doesn't want me, and hell is afraid I'll take over
Was this reply relevant?
+0
-0

This thread has been marked as locked.