Forum Thread: can't seem to turn off auto update on those programs which allow it

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI 2.0 Beta

This thread has been marked as locked.
bhenshaw can't seem to turn off auto update on those programs which allow it
Member 1st Oct, 2010 01:26
Ranking: 40
Posts: 85
User Since: 29th Apr, 2009
System Score: N/A
Location: US
Last edited on 1st Oct, 2010 01:27

I can't seem to turn off auto update on those programs which allow it.

I tried double clicking on the program and unchecking the box labeled "Auto-Update this program:" and then closing the window.

However, when I went back in and looked the box was checked again.

Thanks,

Bill

Maurice Joyce RE: can't seem to turn off auto update on those programs which allow it
Handling Contributor 1st Oct, 2010 01:30
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Bill,
Open the Configuration Box from the dashboard. Select Settings - remove the tick (check mark) from the clearly defined setting option.

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+1
-0
bhenshaw RE: can't seem to turn off auto update on those programs which allow it
Member 1st Oct, 2010 01:33
Score: 40
Posts: 85
User Since: 29th Apr 2009
System Score: N/A
Location: US
Maurice,

Thanks for the quick response. However... I wasn't trying to turn off auto updating for all programs, just for a couple that I would prefer more control over. It seems like you should be able to turn it off for a specific program by unchecking that box in the details for the program. Is that not the purpose of that check box?

Thanks,

Bill
Was this reply relevant?
+0
-0
Maurice Joyce RE: can't seem to turn off auto update on those programs which allow it
Handling Contributor 1st Oct, 2010 01:43
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Click on LEARN MORE>Secunia PSI Manual (PDF) - it explains everything about PSI Beta - section 4-4 is all about auto/manual updates.

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+0
-0
bhenshaw RE: can't seem to turn off auto update on those programs which allow it
Member 1st Oct, 2010 01:50
Score: 40
Posts: 85
User Since: 29th Apr 2009
System Score: N/A
Location: US
Maurice,

Actually, I had read through that. It says the following...

"The "Enable automatic program updates" check-box determines whether the Secunia PSI should make use of it's capability for automatic updates. When checked, it will attempt to automatically update any program for which this is possible, without requiring any user intervention. When not checked, programs have to be upgraded manually. If there is a particular program you prefer not to auto-update, you can go to the Results-tab and double-click the program. Remove the check at the Auto-Update checkbox, and the program will no longer be automatically updated."

The last two sentences are what I tried to do, but it doesn't work. I unchecked the box and closed the window, but when I went back in the box was checked again.

So... I was wondering if what is happening for me was a bug. I guess it is.


Bill
Was this reply relevant?
+0
-0
Maurice Joyce RE: can't seem to turn off auto update on those programs which allow it
Handling Contributor 1st Oct, 2010 01:53
Score: 12325
Posts: 9,575
User Since: 4th Jan 2009
System Score: N/A
Location: UK
Bill,

Worth leaving this thread open for comment by a Secunia Official.

--
Maurice

Microsoft Surface 4 Intel i7 64Bit
Windows 10 Pro version 1809 Build 17763.404
16 GB RAM
IE & Edge Only
Was this reply relevant?
+0
-0
This user no longer exists RE: can't seem to turn off auto update on those programs which allow it
Member 1st Oct, 2010 09:27
Last edited on 1st Oct, 2010 10:28 Hi,

Thank you for your feedback.

Having looked into it, I can confirm this issue. I will ensure that your comments reach our developers, and that they are made aware of the issue.

If you have any further feedback, comments or suggestions, please do not hesitate to let us know.
Was this reply relevant?
+0
-0
This user no longer exists RE: can't seem to turn off auto update on those programs which allow it
Member 8th Oct, 2010 08:34
Hi,

This issue has been fixed.
If you restart the PSI, you will be able to uncheck Auto-Updates for any applicaitions on your results tab.

hope this helps.
Was this reply relevant?
+0
-0
bhenshaw RE: can't seem to turn off auto update on those programs which allow it
Member 8th Oct, 2010 18:07
Score: 40
Posts: 85
User Since: 29th Apr 2009
System Score: N/A
Location: US
Emil,

Do I have to download a new version of the software first?

Thanks,

Bill
Was this reply relevant?
+0
-0
bhenshaw RE: can't seem to turn off auto update on those programs which allow it
Member 8th Oct, 2010 18:16
Score: 40
Posts: 85
User Since: 29th Apr 2009
System Score: N/A
Location: US
Emil,

I should have tested first... the problem is fixed. Thanks so much!

By the way, how do you do that without a client software update?

Thanks,

Bill
Was this reply relevant?
+0
-0
This user no longer exists RE: can't seem to turn off auto update on those programs which allow it
Member 11th Oct, 2010 09:02
Hi,

While the main program is a regular installed program, the PSI's User Interface is loaded over the network on each startup.

The PSI uses Internet Explorer to display it's user interface, and also loads the PSI from within IE. This is also why settings in Internet Explorer can affect the PSI.

This is also why we can deploy corrections without everybody having to reinstall.

hope this helps.
Was this reply relevant?
+0
-0
bhenshaw RE: can't seem to turn off auto update on those programs which allow it
Member 11th Oct, 2010 18:46
Score: 40
Posts: 85
User Since: 29th Apr 2009
System Score: N/A
Location: US
Very cool.

Thanks for the explanation and the fix.

Bill
Was this reply relevant?
+0
-0

This thread has been marked as locked.