Forum Thread: TrueCrypt

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
Programs

Relating to this vendor:
TrueCrypt Foundation
And, this specific program:
TrueCrypt 6.x

This thread has been marked as resolved.
gwilki TrueCrypt
Member 5th Nov, 2010 14:21
Ranking: 0
Posts: 27
User Since: 19th Dec, 2007
System Score: N/A
Location: CA
Last edited on 5th Nov, 2010 14:22

I'm still using PSI 1.5.0.2.

Yesterday, it started reporting that my TrueCrypt 6.3.1.0 was end of life and that an executable that I had saved in a downloads folder truecrypt.exe was also end of life.

I upgraded to TrueCrypt 7.0a. PSI still shows that I have 6.3.1.0 installed. It is not. It was overwritten by the new version.

Also, there is no file truecrypt.exe in my downloads folder. There was the executable for the previous 6.3.1.0, but I deleted it. The only executable in that folder now is the one for the new version 7.0a and it is not named truecrypt.exe.

This is not a big deal from a security standpoint. I just wanted to report it so that at some point it can be addressed.

Post "RE: TrueCrypt" has been selected as an answer.
This user no longer exists RE: TrueCrypt
Secunia Official 5th Nov, 2010 14:36
Hi

Have you checked the location of the detected End-of-life TrueCrypt that the PSI provides?

You might have to make a full scan after you have deleted the old files.
gwilki RE: TrueCrypt
Member 5th Nov, 2010 14:49
Score: 0
Posts: 27
User Since: 19th Dec 2007
System Score: N/A
Location: CA
I have checked the location of both end of life issues.

One is the actual program file that is installed. There is a file named truecrypt.exe in that folder. But, it is not the version that PSI says it is. The version number reported by both Truecrypt and MS is 7.0.1.0. PSI says it is 6.3.1.0, which was the former version that I had installed.

I've done a full system scan, as you suggest. The issue remains.


I found the issue with the file in the downloads folder. It was my error and not PSI's.



Was this reply relevant?
+0
-0
This user no longer exists RE: TrueCrypt
Secunia Official 5th Nov, 2010 15:06
I could imagine that a program like TrueCrypt requires a restart in order to complete the uninstallation completely.

Have you tried that?
gwilki RE: TrueCrypt
Member 5th Nov, 2010 15:23
Score: 0
Posts: 27
User Since: 19th Dec 2007
System Score: N/A
Location: CA
Yes, I restarted when I installed it. Since then, the PC has been restarted twice.

As I said, I'm not concerned about his. I only reported it so that Secunia is aware of the issue.

Thanks for looking into this. If there is anything I can do to help Secunia with this, let me know.
Was this reply relevant?
+0
-0
This user no longer exists RE: TrueCrypt
Secunia Official 5th Nov, 2010 15:32
I've updated our rules a bit:

TrueCrypt 7.x should be detected as 7.0a instead of 7.0.1.0

Does the problem persist?
gwilki RE: TrueCrypt
Member 5th Nov, 2010 15:37
Score: 0
Posts: 27
User Since: 19th Dec 2007
System Score: N/A
Location: CA
The issue is gone! That was quick.

Thanks much.
Was this reply relevant?
+0
-0

This thread has been marked as locked.