Forum Thread: PSI 2.0 hung at Verifying Internet connection...

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
jmeyers PSI 2.0 hung at Verifying Internet connection...
Member 1st Mar, 2011 14:21
Ranking: 1
Posts: 3
User Since: 26th Nov, 2008
System Score: N/A
Location: N/A
PSI 2.0 stopped working all of a sudden. At first thought it might be due to the Microsoft Service Pack SP1, however I haven't installed it on my work machine but have on my home machine. When opening PSI both machines were displaying the same instance of hanging at Verifying Internet connection...
Work machine is running Win7 Professional 64 bit, home machine Win7 Home Premium 32 bit.

I've corrected this hang by uninstalling PSI and downloading and running setup within Internet Explorer. This did not work within Firefox! Why would that be I wonder? I have IE turned off on my home machine, could be a problem.
Does Secunia need to make PSI more compatible with Firefox?

Jesant13 RE: PSI 2.0 hung at Verifying Internet connection...
Member 1st Mar, 2011 14:58
Score: -3
Posts: 41
User Since: 10th Sep 2009
System Score: N/A
Location: US
I'm glad I'm not the only one having this problem. I hope it will be resolved soon.
Was this reply relevant?
+2
-0
kaisersoze RE: PSI 2.0 hung at Verifying Internet connection...
Member 1st Mar, 2011 21:43
Score: 0
Posts: 11
User Since: 11th Jan 2010
System Score: N/A
Location: SE
I downloaded the PSI setup via FF and did a reinstall then it started to work again


--
Windows 7 x64 + PSI 2.0 Beta (v1.9.0.5004)
Was this reply relevant?
+2
-0
joe schmoe RE: PSI 2.0 hung at Verifying Internet connection...
Member 1st Mar, 2011 22:31
Score: 41
Posts: 144
User Since: 26th Nov 2008
System Score: N/A
Location: US
Last edited on 1st Mar, 2011 22:58
jmeyers,

It seems your issue may have to do with the version of PSI you may be currently running. Others have posted recently in this forum stating the exact same issue you have, and of those, some have downloaded the most recent version of PSI, v. 2.0.0.3001. This version seems to clear up the issue of being stuck at 'Verifying Internet Connection' issue you seem to be having.

Uninstalling the older version (you can check this by right-clicking the system tray icon and clicking 'About') and installing the newest version should work.

Get the latest version from the download link above at 'Download PSI' on this page.

Several people have said that there was no notification that there is a newer version available here, so I hope this helps.

XP Home SP3, PSI v. 2.0.0.3001

joe schmoe

EDIT: For your convenience, I have included a link provided by mogs in another post: http://secunia.com/vulnerability_scanning/personal... and also http://secunia.com/vulnerability_scanning/personal... which is the original link provided by mogs.

--
XP Pro SP3 P4 3.2 HT 2 GB RAM Avast! 9.0.2018 AIS
Win 7 Home Pro SP1 Pentium D 2.8 3 GB RAM Avast 9.0.2018 AIS
Secunia PSI 2.0.0.3003 XP Pro 32-bit & Win 7 H Pro 64-bit
Was this reply relevant?
+3
-1
jmeyers RE: PSI 2.0 hung at Verifying Internet connection...
Member 2nd Mar, 2011 01:24
Score: 1
Posts: 3
User Since: 26th Nov 2008
System Score: N/A
Location: N/A
Last edited on 2nd Mar, 2011 02:04
Thanks for the reply Joe. The version you mention is the one I uninstalled and downloaded again. I am still having the same issue on my home machine even after enabling internet explorer and installing PSI from within IE. That worked on my work machine but not at home. Maybe a difference between 64 bit (work) and 32 bit (home)?
********************************************

Found the answer that worked for me anyway!

See below from the FAQ's...

The Secunia PSI is stuck at "Verifying Internet connection..." and won't start. What can I do?

The Secunia PSI needs to be able to connect to Secunia's servers to complete a scan. To make this possible, you may need to change some of your Internet options.

To do this:

1. Open the control panel
2. Open Internet Options > Security tab. In Windows7/Vista you may need to click 'Network and Internet' to access the Internet Options
3. Select the Internet zone and click on the Custom Level button.
4. In Security Settings, go to the Scripting>Active Scripting option.
5. Make sure that Active Scripting is enabled (rather than Disabled or Prompted).
6. Press OK then Yes.
7. Back in the Security tab, select the Trusted sites zone and click on the Sites button.
8. Type in the following and press the Add button to add it to the Trusted Sites list:
https://*.secunia.com
9. Press Close, then OK.
10. Run the Secunia PSI again to view the scan results.

P.S. I did not have to enable active scripting in order for PSI to function again.
We have been instructed by, among others, Windows Secrets, to disable this setting for security. It would be nice if the organizations who are trying to be helpful in getting us secure could get on the same page.
Best regards,

jmeyers
Was this reply relevant?
+1
-0
Jesant13 RE: PSI 2.0 hung at Verifying Internet connection...
Member 2nd Mar, 2011 16:14
Score: -3
Posts: 41
User Since: 10th Sep 2009
System Score: N/A
Location: US
Thank you joe schmoe for your response. I confirmed that I was using version 2.0 instead of version 2.0.0.3001. I was never notified that there had been an update.

I uninstalled version 2.0, shut off my computer, turned it back on, and installed version 2.0.0.3001. After the installation, I ran the program and it was working normally. After it automatically scanned my computer, I turned my computer off and then turned it back on. It started up in the system tray and when I tried running the program it worked correctly.

Again, thank you for your help. I am glad that Secunia PSI is functioning correctly again on my computer.
Was this reply relevant?
+2
-0
This user no longer exists RE: PSI 2.0 hung at Verifying Internet connection...
Member 5th Mar, 2011 06:49
Hello I am also having this problem on several computers. The all have version 2.0.0.1003. Everything was working fine until a few days ago. It's going to be a pain to reinstall this on many computers. Also I suggested this to friends who have it on their computers and it would take effort to explain this.

Has the problem been identified?
Was this reply relevant?
+2
-1
IcI RE: PSI 2.0 hung at Verifying Internet connection...
Member 5th Mar, 2011 09:49
Score: 8
Posts: 8
User Since: 13th Jan 2010
System Score: N/A
Location: NZ
Last edited on 5th Mar, 2011 09:51
Looking at other posts and my own experiences; no, this problem has not been resolved.

I've changed the settings as per the FAQ, un-installed, rebooted, re-installed, looked at log files. No luck. Don't know what to try next.

PS Doesn't help to have confusing version numbers like .1003 and .3001
Was this reply relevant?
+1
-0
Anselm RE: PSI 2.0 hung at Verifying Internet connection...
Member 5th Mar, 2011 10:11
Score: 7
Posts: 40
User Since: 7th Jul 2008
System Score: N/A
Location: DE
on 2nd Mar, 2011 01:24, jmeyers wrote:
To do this:

1. Open the control panel
2. Open Internet Options > Security tab. In Windows7/Vista you may need to click 'Network and Internet' to access the Internet Options
3. Select the Internet zone and click on the Custom Level button.
4. In Security Settings, go to the Scripting>Active Scripting option.
5. Make sure that Active Scripting is enabled (rather than Disabled or Prompted).
6. Press OK then Yes.
7. Back in the Security tab, select the Trusted sites zone and click on the Sites button.
8. Type in the following and press the Add button to add it to the Trusted Sites list:
https://*.secunia.com
9. Press Close, then OK.
10. Run the Secunia PSI again to view the scan results.

I had the same problem. Updating to v. 2.0.0.3001 and following your instructions fixed it.

Thank you,

Anselm


--
Secunia PSI 3.0
Windows 7 Professional 64 Bit SP1
Intel Core i5-2430M CPU 2.4 GHz 8 GB RAM
Was this reply relevant?
+2
-0
dehughes RE: PSI 2.0 hung at Verifying Internet connection...
Member 5th Mar, 2011 13:15
Score: 1
Posts: 1
User Since: 5th Mar 2011
System Score: N/A
Location: US
Same problem on five systems.

It was working on all of them before.

I Do not have IE on two of them, so the above suggestion about security zones is not available.


--
...don
Was this reply relevant?
+1
-0
This user no longer exists RE: PSI 2.0 hung at Verifying Internet connection...
Member 5th Mar, 2011 18:47
I added https://*.secunia.com to trusted sites. This was not on any computer before but it is now. Still though, it hangs. I'm going to sniff the traffic and see what it shows
Was this reply relevant?
+1
-0
Beercow RE: PSI 2.0 hung at Verifying Internet connection...
Member 6th Mar, 2011 01:45
Score: 33
Posts: 34
User Since: 26th Sep 2010
System Score: N/A
Location: US
I found an answer to the problem of the UI freezing on start up. It worked for me, I hope it works for you. I am using Windows 7 64bit.

You should delete 1 extra (parasite) zone from

HKEY_CURRENT_USER\Software\Microsoft\Windows\Curre ntVersion\Internet Settings\Zones\

with pseudo-graphic number, you'll see it before zone number 0.

It seems this is a bug of Adobe flash player update, though I am not sure.

P.S. By the way, this extra zone prevents desktop gadgets to be shown correctly.

I forgot to mention, always back up your registry before making any changes.


--
Beercow

Windows 7 Professional SP1 64bit
Amd Athlon IIx4 630 Quad-core
Firefox 11
6GB ram
Was this reply relevant?
+2
-0

This thread has been marked as locked.