Forum Thread: Auto-Updates not working - stuck with "Determining Auto-Update St...

You are currently viewing a forum thread in the Secunia Community Forum. Please note that opinions expressed here are not of Secunia but solely reflect those of the user who wrote it.

This thread was submitted in the following forum:
PSI

This thread has been marked as locked.
Gurkenpapst Auto-Updates not working - stuck with "Determining Auto-Update State"
Member 20th May, 2011 20:04
Ranking: 0
Posts: 2
User Since: 20th May, 2011
System Score: N/A
Location: DE
I have a problem with PSI on one computer, where automatic updates stopped working with no apparent reason. The column "Install Solution" either only shows "Install Solution" or (after disabling an re-enabling automatic updates) "Determining Auto-Update Status", while the checkboxes for "Enable automatic program updates" and "Auto-Update this program" are checked. This problem affects all programs that usually are auto-updated by PSI, (e.g. Adobe Flash Player, Sun JRE, Firefox, ...).

I have read the FAQ and searched the forums, but it seems I am the only one being stuck with "Determining Auto-Update State". I also checked if the services "Secunia PSI Agent" and "Secunia Update Agent" are running. They both are. Also stopping and restarting these services and even reinstalling PSI did not fix it.

A probably interesting part of psialog.txt follows:

[05/20 19:38:35.500] notifying :: 1 :: sua
[05/20 19:38:35.531] Setting state of 'Sun Java JRE 1.6.x / 6.x' to determining
[05/20 19:38:35.531] Setting state of 'XnView 1.x' to determining
[05/20 19:38:35.531] Setting state of 'Foxit Reader 4.x' to determining
[05/20 19:38:35.546] Setting state of 'ImgBurn 2.x' to determining
[05/20 19:38:35.546] Setting state of 'WinRAR 3.x' to determining
[05/20 19:38:35.546] Setting state of 'Mozilla Firefox 4.0.x' to determining
[05/20 19:38:35.546] Setting state of 'AdobeFlashNPAPI' to determining
[05/20 19:38:35.562] notify done
[05/20 19:41:05.765] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:41:05.968] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:41:06.078] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:41:06.453] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:41:06.546] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:41:06.656] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:41:06.703] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:41:06.703] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:41:06.703] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:41:06.703] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:41:06.718] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:41:06.718] Exception in RequestUI : -2146823281 , 'auState.ui.error' ist Null oder kein Objekt
[05/20 19:42:40.546] Checking in with server (psi.secunia.com)

And some more:
[05/20 19:49:51.640] Temporary directory is:C:\WINDOWS\TEMP\\Secunia PSI Agent
[05/20 19:49:51.640] Couldn't delete file/directory C:\Programme\Secunia\PSI\SUA\a51058b95efb47161d76a e95282ccb50
[05/20 19:49:52.078] Periodic Exception (pr:70) : -2147024893 , Das System kann den angegebenen Pfad nicht finden.
[05/20 19:49:53.921] Periodic Exception (pr:70) : -2147024893 , Das System kann den angegebenen Pfad nicht finden.

I guess these exceptions are related to the problem. Also interesting: sualog.txt is not created, but the service is reported as running and sua.exe is showing up in task manager. Deleting C:\Programme\Secunia\PSI\SUA\ results in

[05/20 19:56:54.843] Error reading ACLs on SUA directory, 0x00000002, Das System kann die angegebene Datei nicht finden.
[05/20 19:56:54.843] cd Error : Error reading ACLs on SUA directory, 0x00000002, Das System kann die angegebene Datei nicht finden.
[05/20 19:56:54.843] EnforceDir done

so I guess this shows SUA is indeed running?

Is there any advice to fix this problem or at least to pin down it's source?

xyzzy RE: Auto-Updates not working - stuck with "Determining Auto-Update State"
Member 20th May, 2011 22:02
Score:
Posts: 41
User Since: 7th Mar 2008
System Score: N/A
Location: DE
In your situation I'd uninstall PSI, and then install it again. Of course it would be interesting to know what's wrong, but above all I want PSI to do its job.
Was this reply relevant?
+0
-0
Gurkenpapst RE: Auto-Updates not working - stuck with "Determining Auto-Update State"
Member 20th May, 2011 23:21
Score: 0
Posts: 2
User Since: 20th May 2011
System Score: N/A
Location: DE
Probably I was not precise enough, when I wrote about reinstalling, I uninstalled PSI before (this alone should be irrelevant, because the installer otherwise does it on its own) and then deleted the leftovers in the program directory. But maybe there are more things left in another place. I would be glad to try it again, if you could point out these locations.
Was this reply relevant?
+0
-0

This thread has been marked as locked.